Android App - testers wanted for updated version

feature-request
user-interface
client-apps
Tags: #<Tag:0x00007fe8916b6f58> #<Tag:0x00007fe8916b6440> #<Tag:0x00007fe8916b6080>

#20

Thanks. I found the file and am sending to myself via Cloud Drive.

I will let you know if it works.

Thanks for the help.


#21

All,
Please try out the updated version of the Android app before it goes live in the app store:
https://drive.google.com/file/d/13VwlZ7xLs2fACRNJncMTotumosHojY-x/view

We look for reports of any issues or oddities.
Thank you!


Android app never shows door closed unless app is closed and restarted
#22

I just installed the beta, and it shows that my door is open half way. It is not. I’ve opened and closed it a few times, but it always shows half open when I refresh. This is also the case from the web view.


#23

Daryl,
Please close the door using the wall button and make sure the app reports the door as closed.
If it doesn’t, then please make sure the laser is pointed at the center of the reflective tag and the reflection reported in settings is well above the threshold value.


#24

Hi All,
New version of Android app is ready for testing:
https://drive.google.com/file/d/1pOCMFgsZCcY71miaNpoMKzbTrYSlHzy-/view

In this version:

  • fixes and behavior improvements in settings
  • improved compatibility with the new Android OS and lates hardware (e.g. Pixel Phones)
  • improved doors status update when it is operated outside of the app
  • latest Particle SDK

Your feedback and issue reports are greatly appreciated.


#25

Looks like it killed my notifications.


#26

same here using new APK above and getting no notifications on my note 9
and yes I have notifications allowed in settings for the app and I have it set on the android settings to allow notifications too

Hope you can make a fix for this, thanks for a GREAT PRODUCT!


#27

@TLATACKI & @dallasnights,
Thanks. Do you get notifications back if you logout and log back in?
Also try toggling one of the notifications off and later back on. Does that help?
While testing please keep in mind that notifications are suppressed when app is active so exit to main screen and operate the door from another device or using wall button.


#28

If I want to test the new version, should I simply install it (update) over my existing app or should I uninstall the app first?


#29

From what I remember the installer asks if you want to replace the existing app.


#30

I’ve upgraded my existing app and I can confirm that I am no longer receiving alerts. Here are steps I’ve taken to attempt to resolve, but none have worked. I did all my testing with the app not active on my device.

  1. Turned off a notification, exit, relaunch, turn back on.
  2. Tapped the “Authenticate” menu and re-entered credentials.
  3. Tapped the “Logout” menu, exited, used the “close all” on recent apps list, relaunch and entered credentials.
  4. Attempted #1 again.
  5. Logged out, uninstalled app, reinstalled the beta, relaunched (note even though I uninstalled it did not ask for credentials) tapped logout, reentered credentials
  6. Uninstalled. Reinstalled from store. (notifications still did not work with this version) Reupgraded to beta

That’s where I’m sitting so far. I wonder if something has changed with the app that requires the push notifications to be reset at the server like you’ve done for me before.

-Joel


#31

Joel,
Thanks for the detailed info. I’m looking into it…


#32

Here is a new binary:
https://drive.google.com/file/d/1QC_lbFYHxWPfd9lPeyfVFYX_-tbiqKyZ/view?usp=sharing

It has push notification subscription code fixed. Thanks all.


#33

I updated to the new binary (quick turnaround!!!), unfortunately it did not resolve the issue. I have went through the steps that I mentioned above and it still isn’t notifying me. Even the current version in the store has stopped providing notifications so I don’t know if something got messed up with the AWS subscriptions or if there’s something else going on. Are there any debug logs that I can send, or does it already do that?


#34

good job the one I just got an update on the playstore on android works well and gives me the notification back! Thank you!


#35

I have started receiving notifications at lease open and close - haven’t checked the other one for night yet


#36

New binary is available. This should resolve device setup issue on some Android devices:


#37

Thanks! Installed and it seems to be working good, including notifications!


#38

I tried to install
https://drive.google.com/file/d/0By5zUvjs1Vk7bmNLTllKMlBvYzQ/view?usp=sharing

I get an error “App not installed”

Also, i think I have version Ver 1.20 intalled. Is that newer?


#39

Yes, this download shows version 1.20
If you have any doubts, you can clear the app’s data via settings, uninstall the old version and then re-install this one from the download link.