Encryption key fix (fast cyan blinks with occasional red)

Tags: #<Tag:0x00007f7d9cb9bb00>

If your Garadget is unable to connect with LED fast blinking cyan with an occasional red, then its encryption key needs to be refreshed. Please contact Garadget via a PM (personal message) to arrange the repair.

Those who are comfortable with technology are welcome to attempt the process at home. It only takes a minute, but the software takes longer to setup first time.

You’ll need [ Windows CLI Installer and public encryption key - cloud_public.der.

The process:

  1. Install the software, and download public key to current directory
  2. Connect your Garadget to computer using microUSB cable, you should see a new COM port in device manager
  3. Press and hold “M” button until LED switches to blinking dark blue (Listening Mode)
  4. In console run command particle identify to get your Garadget’s device ID
  5. Run command particle login to login into your Garadget account
  6. Hold “M” button and click “R” button, release when LED switches to blinking yellow (DFU mode)
  7. Run following commands one after another:

dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der
particle keys server cloud_public.der
particle keys new photon
particle keys load photon.der
particle keys send [device id] photon.pub.pem

Please post your questions and help requests relevant to above process in this thread.

Unable to re-setup device
Garage is offline
Unable to re-setup device
My garadjet shows 8 days offline
Cannot see WiFi network
Garadget iOS App Showing Offline
Offline for many days

I am having the same issue, first started occurring the other day. I went through the post above (Encryption key fix (fast cyan blinks with occasional red)) and I got ‘permission denied’ at the last stage. PSB the full output.

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device…
ID 2b04:d008
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash "
Downloading to address = 0x00000022, size = 608
Download [=========================] 100% 608 bytes
Download done.
File downloaded successfully
attempting to add a new public key for device 5**************3
Error sending public key to server: Permission Denied
Make sure your device is in DFU mode (blinking yellow), and that your computer is online.
Error - undefined

It then started blinking green, fast. I searched around as you do, and ended up running the following commands, which seemed to change the way it behaves (at least the LED blink sequence):

particle keys server cloud_public.der particle keys new photon particle keys load photon.der particle keys send photon.pub.pem

This seemed to (sort of) work, but upon reboot it now flashes cyan fast, then yellow slow 3 times, then repeats, occasionally blinking fast green between every few sequences. I have attempted to add my device via the normal method via the app but no joy, I get the following message:

'Setup Completed
Your device has been successfully claimed to your account, however it is offline. If the device was already claimed before this setup then the Wi-Fi connection may have failed, and you should try setup again. ’

This is the same message I have got since attempting to get this back online again.


You made a great progress with the key update and you’re almost there.
To resolve the permission issue, please try following:

particle device remove [device id]

then as previously attempted

particle keys send [device id] photon.pub.pem

and after that

particle device add [device id]

if you encounter any issues with these steps, please don’t hesitate to reach out to me


Thanks very much for that - falling at the last hurdle. When I run the last step I get this:

Claiming device 5{}3
Failed to claim device, server said: Device is not connected

I have tried this in dfu mode and after a reset.

When I reset, I still get the cyan/yellow/green flashing light combo

UPDATE: I tried to re-enroll the device with the app, and it gets most of the way through, eventually ending in this message:

Setup process failed at claiming your particle device. If your Particle device LED is blinking in blue or green this means that you provided the wrong Wi-Fi credentials, please try setup process again.

I now am back where I started with a flashing cyan/red light, except this time the laser is working.


Thanks for the update.
Please try repeating the encryption key fix steps so you complete the whole process in one session without any errors. You can start with removing the device from account to avoid the permission issue closer to the end. Please let me know how this goes.


Already tried it a couple of times. When I try it again I get:

particle device remove 5[]3
Are you sure? Please Type yes to continue: yes
releasing device 5[]3
Didn’t remove the device Permission Denied

I might add that I’ve tried the last stage during a re-enrollment on the app, to ensure the device is actually connected. It passes every step aside from the ‘Claiming Device’ step at the end, whereby it starts the cyan flashing LED again.


I checked on the server and your device is already removed from the account. Please give the rest of the process another run and if that doesn’t get it online, please send your Garadget back for warranty repair/replacement.


I’ve done it a bunch of times already - it’s definitely not working. It’s very frustrating because the device works, connects to the Wifi, but doesn’t like the server connection for some reason. Surely there must be another way of figuring out why this is not working without having to send it back to the US (I am in the UK).

Is there a way to do a complete factory reset?

Maybe there’s a version of the firmware I could flash back to which would work?

Sending it back is going to be a very last resort. What’s the use of something being open source if you have to send it back for repair when the software fails?


Shipping back wouldn’t be a big of a deal domestically, but I agree it’s a bit more of a hassle when crossing the ocean is involved. Let’s try a remote access session (more details in PM).


Same problem. How do I go about exchanging device?


I got it working, but these instructions left out a few steps that I had to figure out. I’ve only done this once, so feel free to correct me if I’m off base anywhere.

Prep Work…

  1. Hold down BOTH buttons
  2. Release only the RST button, while holding down the MODE button.
  3. Wait for the LED to start flashing yellow
  4. Release the MODE button "

Then do these 4 commands that @garadget shared (ofcourse make sure you copied the .der file to your local path)

fu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der
particle keys server cloud_public.der
particle keys new photon
particle keys load photon.der

And some others…

particle cloud login

(follow login prompts)

particle device remove [device id]

particle keys send [device id] photon.pub.pem

“particle device add [device id]” didn’t work for me so I plugged the device back into its brick and pressed the M button for 3 seconds to re-claim it and set it back up.


Thanks for the write up. All looks good except you could use your existing Garadget account to login into Particle CLI instead of creating a new/generic one.

1 Like

Hi, For any Mac / Linux users, here is a step by step that may help:

  1. Open Terminal
  2. Paste the following: bash &lt;( curl -sL https://particle.io/install-cli )
  3. Install Homebrew: /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
  4. Install DFU-Util brew install dfu-util
  5. Download the Encryption Key (as written by garadget above)
  6. Hold Down “M” and “R” on the Garadget and connect it to your computer. Let go of “R” It will flash Purple and then a Yellow / Green colour, once it is Yellow / Green, you can release “M”
  7. Assuming that you downloaded the .der file above to downloads, the command will be similar to this (replace yourusernamegoeshere with whatever your username is on your machine) dfu-util -d 2b04:d006 -a 1 -s 2082 -D /users/yourusernamegoeshere/Downloads/cloud_public.der
  8. On my machine (Mac running OS X Mojave 10.14.2) I had to change directory over to where Particle was installed so cd ~/bin
  9. Assuming that you downloaded the .der file above to downloads, the command will be similar to this (replace yourusernamegoeshere with whatever your username is on your machine) ./particle keys server /users/yourusernamegoeshere/Downloads/cloud_public.der
  10. ./particle keys new photon
  11. ./particle keys load photon.der
  12. You will need your Device ID at this stage, head to: Garadget Login and click settings and copy your “ID” or type ./particle identify
  13. ./particle cloud login and enter your email address and password when prompted
  14. ./particle device remove YourID_From_Step_12
  15. ./particle keys send YourID_From_Step_12 photon.pub.pem
    If it worked, you should see:

submitting public key succeeded!

1 Like