Garadget Android Beta App 2.06 crashing on startup

Hi, just wanted to let you know that the Garadget Android Beta App 2.06 is crashing on startup on my OnePlus 8 Pro. I have sent you diagnostics using Android built-in error reporting mechanism.

I know this is a beta app and this is to be expected, but I just wanted to report the bug, just in case you hadn’t noticed. If I can provide some more information, don’t hesitate to ask.

Thanks for your report!

Same situation here with a Samsung S9. The last beta version worked ok…

Same here on oneplus 7

Thank you for your reporting.
The updated version 2.0.6+14 should be replacing the beta version that was crashing.
Please let me know if the issue persists.

I’ve just downloaded what I think is the latest version from the Play Store & have the same issue with the app crashing

I just checked for updates and the app did update. However, it’s showing 2.0.6 and I’m still crashing immediately on Android 10.

2020-08-17 14:18:42.567 11788-11788/? E/AndroidRuntime: FATAL EXCEPTION: main
    Process:, PID: 11788
    java.lang.IllegalAccessError: Interface androidx.lifecycle.b implemented by class io.flutter.plugins.googlemaps.GoogleMapsPlugin is inaccessible (declaration of 'io.flutter.plugins.googlemaps.GoogleMapsPlugin' appears in base.apk)
        at f.a.d.a.b(Unknown Source:0)
        at Source:3)
        at android.os.Handler.dispatchMessage(
        at android.os.Looper.loop(
        at java.lang.reflect.Method.invoke(Native Method)

Edit: It looks like this might be ab issue with flutter and gradle version 4.
See this link:

Hi. I have downloaded the new version and the problems persists. The app crashes immediately

Thanks for the additional info. Researching this issue now it makes sense that it slipped by the testing.
It only manifests itself when the app is packaged for the publishing, but not when in development.
There are some workarounds discussed, I’ll give those a try. Please stay tuned.

EDIT: Until there is a solution, the beta release is suspended. You can revert to the stable version by re-installing the app. Thanks to all beta testers for your reports.

Hi again. I have desinstalled the app and installed again (it appears to be the version published on May, 2nd) but…still the same problem. The app crashes during the opening.
In addition I have erased the app data and cache, but it doesn’t solve the problem.

Please check the bottom of the listing for this message:

If you see it, you can leave the program and re-download the app.
Later, after this beta is fixed you can re-join the program if you still want the early access.

:+1:Thank you

Can anybody confirm the installation of new beta (2.0.6+15)?

Hi… now it works!!! Thanks a lot.

1 Like

Working great now Denis thank you :grin::grin::+1::+1::grin::grin:

1 Like

Working - With the previous was there a way to see the +?? version since it closes - I only saw 2.0.6 on the app info

1 Like

We’ll keep beta going for few more days and then release to the general public.
Please report if you encounter any issues.
Also, check out the long press on the app icon. The individual entries from there can be dragged to the home screen as separate command icons.

Thanks, all.