Google Assistant suddenly can't control Garadget via IFTTT

I have been using Garadget for almost a year now. It’s a great little gadget and I love it that I can control open/close my garage door via Google Assistant (through IFTTT). Just yesterday night, such function no longer works anymore. I disconnect/reconnect the applet and that usually fix the problem. But not this time. Google will respond saying my garage door is not setup. I changed the phrase and that didn’t work either.

Is anyone else having the same issue? I feel like the issue is happening between IFTTT and/or Garadget applet.

Yes, I’m having issues as well. The last time IFTTT successfully triggered or was triggered by Garadget was 8/4. On 8/5 and every day since, I have been getting this error:

“Garadget error: 400: Error writing database: ValidationException: One or more parameter values were invalid: An string set may not be empty”.

Today, I attempted to disconnect the service and reconnect it to IFTTT. I keep getting the error “Could not connect. Please try again later.”

Thanks for reporting the issue. I ran API tests and all came back green, but there are log entries for the error message you reported. Please try re-connecting the service again and PM me the device ID if that fails again. Meanwhile I’ll look at the previous error reports to see what is special about those requests.

It is working now. I had to edit my account info in IFTTT and authorize it by logging in again. After that, I was able to reconnect. I tested everything and all seems good.


1 Like


I tried at least a dozen times to reconnect the service and it is still not working as expected. Since Friday night, GA will accept my command to open the garage (instead of asking me to setup device) and respond to me. But the garage door never opens. I checked the applet in IFTTT and it is able to connect properly. But I can’t use GA the control the device. Please advice on how to troubleshoot the issue. Thanks

You can try a different applet (e.g. widget button to open/close door) to determine if the issue is on Garadget end or on the Google Assistant’s.

Keep in mind that GA’s invocation should not have any punctuation.

Thanks. So I created a widget button as you suggested and it works. So, what should I do next? My GA command is simply “open garage door”. GA will respond to my command but the garage door wouldn’t open. And I checked the applet, it says the app never ran. I also checked the status and everything checked out fine.

If widget works and the applet shows never invoked then the issue is on trigger/GA side.
You can use troubleshoot it separately from Garadget by using an alternative action, e.g. push notification or something else.

BTW: I assume you tried pre-made applets for this: