Google Assistant through IFTTT


#1

I had a custom Google Assistant applet created to open and close the garage door (since the ones int he Gargadget IFTTT didn’t work). It was working fine up until a week or two ago. Now, when I say “Open (or close) garage door,” it just brings up web search results. I am using the Button widget successfully through IFTTT so not sure what the problem is. Any advice would be appreciated.

Thanks!


#2

If widget button works through IFTTT then there is no problem with the authentication.
Please try to deactivate/activate your custom applet. If that doesn’t solve the issue, please try re-creating it.


#3

Unfortunately, that was one of the first things I tried. But re-creating the applet does not work. Before I did that, the activity log showed that it was working for a time.


#4

You can try creating another applet with a different trigger, but with the same Garadget action.
Depending on how that works out, you’ll know if it’s the trigger of action that failing.


#5

I had been using the Garadget (simple) open/close applets through IFTTT. They were working fine when I set them up a short while back. But since then they had stopped working. Google Assistant thinks the applets executed successfully but my Garadget never actually runs the command. I removed the applets in IFTTT but when I tried to reinstall them I get a 404 error. Has anybody else encountered this or have a solution? Thanks.


#6

@egeek,
What is the URL that gives you 404?


#7

It’s actually when I try to turn on the applets in the IFTTT app on my iPhone. It brings up the configure screen where I can specify response phrases from the Google Assistant and it refreshes after a brief pause and says “Request failed: not found (404)”.

Thanks.


#8

@egeek,
Please try IFTTT’s web interface in case there is some issue with their app.


#9

From a web browser I get a message that says “We can’t access your service”.


#10

@egeek, please see if disconnecting and re-connecting Garadget service in your IFTTT account resolves this issue.