HomeKit Integration with Homebridge-Garadget Plugin

Tags: #<Tag:0x00007f7c7e313790> #<Tag:0x00007f7c7e3136c8> #<Tag:0x00007f7c7e313600> #<Tag:0x00007f7c7e3134c0>

I’ve got homebridge running on an RPi. I copy the script in verbatim and get “Config Syntax Error”

“accessories”: [
{
“accessory”: “Garadget”,
“name”: “Garage Door”,
“cloudURL”: “https://api.particle.io/v1/devices/”,
“deviceID”: “<>”,
“access_token”: “<>”
}
]
{
“platform”: “mqtt”,
“name”: “mqtt”
}

What am I doing wrong? I can fill in the deviceID or access_token, doesn’t work either way, still get the syntax error.
Thanks
Rob

Could be the book style quotes “”. In the programming when it comes to double quotes, only the flat version is used ".

Try what garadget suggested and make sure to use

"

quotes

here is a valid one to test without the mqtt platform

{
"bridge": {
	"name": "Homebridge Pi",
	"username": "some-username",
	"port": 51414,
	"pin": "111-22-333"
},
"accessories": [{
	"accessory": "Garadget",
	"name": "Garage Door",
	"cloudURL": "https://api.particle.io/v1/devices/",
	"deviceID": "<>",
	"access_token": "<>"
}]}

Thanks both, I copied and pasted xNinjas script and it worked. NFI what I was doing wrong, nor how to do normal double quotations! It’s not just shift of the single???

Anyway, I’m now getting error messages in the log which just repeat. How do I pause and copy what’s in the log?

Progress but not there yet…

Thanks again,
Rob

Did a screen shot, this is a typed out log:

[date, time] [mqtt] on.close
[date, time] ]mqtt] on.reconnect
[date, time] [mqtt] on.error Error: connect ECONNREFUSED 127.9.0.1:1883 at TCPConnectWrap.afterConnect [as concomplete] (net.js:1141.16) {
errno: ‘ECONNREFUSED’,
code: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘127.0.0.1’,
port:1883
}

Any clues to what to do next. Is the port 1883 correct?

To view the homebridge UI, I use 8581 but in the Config it says 51617

Thanks,
Rob

I am sorry but i didnt write mqtt. You’ll have to check his thread or github. Heres a link to his npm homebridge-garadget-mqtt - npm

These are two different plugins.

Does homebridge rely on mqtt to get the Garadget to work?

Homebridge is a framework used to bridge non apple homekit. Homebridge runs plugins. I am the original creator of the homebridge-garadget plugin for homebridge. There are two different implementations of garadget on homebridge and the other is that mqtt. These two plugins do not interact with each other. I use nodejs and call a couple of dependencies. I use garadget’s api. His uses a open source language and uses login credentials and i think you also need to setup a mqtt server. Doesnt matter which one you choose. I would choose only one if you dont want duplicate garage devices to show up on your home app.

1 Like

Hi xNinjas,

It was my rubbish scripting that was the problem. I moved it’s location and it’s now working a treat =)

Definitely a case of ‘replace user’ to solve the problem! Thanks for creating and sharing the plug in, can’t wait to be able to just tell siri to open and close the garage door in the car.

Thanks,
Rob

Glad you got it to work. Again mqtt is not mine and i cant help support it. If you are using my version then i can help.

In regards to using siri, if you get a security message that you have to accept and wish to bypass it then you can create a second accessory with the bypass switch in config and rename the accessories to a specific name like “castle gate” and siri will see it that name and open with out security message to by pass it.

I use carplay with mine and i can open the garage from my car through my alpine deck.

1 Like

Sorry for the delay, just now came across the post from @Robindra. It doesn’t appear that he’s using the homebridge-garadget-mqtt project. I’m actually not sure which project he’s using.

There are no port options in the config in the homebridge-garadget-mqtt project. The only settings that are required are the mqtt server address and the MQTT channels that are set up in the Garadget UI configuration.

The login credentials are optional. Most MQTT servers like Mosquitto come with it disabled by default. It’s true you need to have an MQTT server but it should be noted there are tons of projects on how to get one of these running quite easily using something like a raspberry pi.

The primary motivation of my project was to have a local cloudless solution because internet outages are very frequent where I live. Your project is suitable for people that want a turn-key solution that works “out of the box”.

Both projects give users a way to interact with their Garadget via Apple devices. I do hope you don’t see the projects as competition but supplement each other very nicely.

@bugs181 no worries. I think the user got confused and thought they needed both plugins. They choose to just use the one with out the mqtt

1 Like