MQTT in hassio stopped working


I have been using garadget since May of 2018 in Hassio with no issues at all (MQTT mode only). It recently stopped giving back sensor values. Status all says “unknown”. I am now on Hassio version 83.3, and I honestly can’t remember in which version it stopped working.

I tried doing MQTT+Cloud and that lets me control the garage via the app, but I prefer to go back to MQTT mode and get sensor values so I can tie in with automations.

I also tried switching from embedded broker to mosquitto addon with no luck.

The garadget was my only mqtt device in my hassio setup, but I did just add a mqtt binary sensor just to make sure I am successfully able to connect to the broker.

Is there a process for RMA if my device has gone bad? I am also open to trying other troubleshooting methods if anyone here is able to help.



Before we go ahead with the RMA: Can you still control your Garadget via the app/web interface?
Did you check new Hassio settings, they now require password. Please see this discussion:


Yes I can still control it via the app.

So garadget requires a mqtt password or hassio does? I now have mqtt setup with no username and password. I used to have a username and password when I used embedded broker.
I was having issues when trying to setup my mosquitto broker to have username and password, I just couldn’t connect to it. But I am also not very experienced with MQTT.

Here is my broker settings:

  "logins": [],
  "anonymous": true,
  "customize": {
    "active": false,
    "folder": "mosquitto"
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"

And here is my configuration file mqtt part:

  port: 1883

  - platform: mqtt
    name: "Garage Door"
    command_topic: "garadget/Garage/command"
    state_topic: "garadget/Garage/status"
    payload_open: "open"
    payload_close: "close"
    state_open: "open"
    state_closed: "closed"
    value_template: '{{ value_json.status }}'


I’ll keep trying and get username and password working in the mean time


Ok I should have read the documents better

For the internal ecosystem we register homeassistant and addons, so these may not be used as user names.

I was trying to use homeassistant as username because that’s what I had before and it worked fine. It is now working when I change username.

Thanks for your response and great product!