Wifi router sees Garadget but it never registers door


#1

Thanks in advance for any assistance.

I bought a refurb unit if that information helps diagnose the problem at all.

  1. I have held down the M button for 10 seconds to force Garadget to forget previous wifi credentials. (slow blue blink, then fast blue blink, back to slow).

  2. Via web/android or Iphone apps everything seems to work as expected until reaching the point of verifying ownership. At this time it progresses no further.

  3. Fast blinking Cyan is occurring on Garadget at this time. My wifi has Garadget registered and the DHCP server has provided it an IP address.

  4. I’m doing all this really close to one of my access points so it certainly isn’t signal strength.

  5. The wifi is set to WPA2+ both TLS and AES as I was trying to make the wifi as compatible as possible.

  6. I tried setting up a port forward for 5683 to Garadget thinking it might need that level of access. It didn’t help.

As I understand this, Garadget is successfully connected to my wifi but unable to communicate with the Garadget server. It’s almost as though the Garadget is locked to some other account, like the previous owner (just a guess).


#2

Thank you for providing your device ID in PM. I don’t see any recent successful connections to the server from that unit.

To rule out network/router issue, you can try setting your Garadget up on a different network (friend’s/neigbour’s/personal AP)? If you get the same result then it may be related to the encryption key. The key can be fixed using the key doctor in command line interface. Please let me know if you prefer to exchange the unit.


#3

Hey Garadget :slight_smile:
Does this look correct? I was confused that “Particle identify” could not see my Garadget. It was in DFU mode and it looks as though “Particle Keys New” was successful. This did not help however. Still did not connect. Same is true for taking it to my neighbors house and attempting to connect it there.

I also attempted to use my android phone as a hotspot and use it’s internet connection to register the Garadget. No luck :frowning:

Any other ideas? Am I not creating the new keys correctly or is an exchange needed?

Thanks for the help


#4

There are other things we can try, but there’s no reason to turn this into a full time job for you.
Please PM me the order info and I’ll arrange the replacement.


#5

I actually rather enjoy the idea that I could fix this one… If it’s not a huge pain to point me in the right direction.

I know how it is though, at some point it’s easier on you to replace it than it is to explain different methods for me to attempt to fix.

If you’re game, I’m game.


#6

You bet I’m game.
Particle’s board describes the range of solutions for the corrupted encryption key, but from what I’m reading this is accompanied by an intermittent red blink between the cyan blinks. Can you check again if this is what’s happening?

In this post there are few additional steps that I haven’t seen in your screenshot. Please check it out.


#7

There is a red blink mixed in the cyan rapid blinks. So it’s likely an key error. I’ll report back after trying some of the solutions in your link. Thanks!


#8

OK: Now I have breathing Cyan. Which I think is good right? But on the web interface it’s still saying “no doors”

I tried various ways of producing new keys and sending them when I finally did this:

https://docs.particle.io/support/troubleshooting/common-issues/photon/

(Public Key Reset portion - If you haven’t ever claimed the device before)


#9

I see your unit online now, but it’s not associated with the user account.
Please try re-adding it to the account by calling “add door” from the app.


#10

When I attempt to re-add via the website:

Through the app it flashes and kicks me back to the main page.

I registered a new account and tried adding the door with that account, it acts like it was added but then shows no door.


#11

This might be the case when you have generic particle account as well as Garadget specific account with the same email address. Please try a native mobile app instead - it will only work with Garadget specific account.

I implemented the web interface so people who want to take their units out of Garadget organization can still login to the web app. I’ll work on the way to resolve the ambiguity when email address is re-used (maybe different login/registration forms for different account types).


#12

I tried through the Particle Android app - photon and I get the “oops - couldn’t claim” message.

I also tried via the cli

Searching particle I can’t seem to find anything on “device not found” Other things for “Failed to claim device” but usually it’s in connection with bad encryption keys or other more obvious things.

Hey, I just have to say thanks for working with me through this. This is support well beyond anything I’d expect for what I paid.


#13

You’re very welcome.
I think we’re past the encryption key issue. If you have a fresh email that you haven’t used for this yet, I’d suggest trying a fresh registration using a native mobile app. I suspect the current challenge has to do with generic Particle vs Garadget organization type accounts.


#14

When you suggest native mobile app are you thinking the Particle Android app or the Garadget Android app?


#15

I suggest Garadget native iOS or Android app.


#16

OK, got it to work! Trick was the IOS app, it registered the door when the android app could not. Even “Particle Device Add” wasn’t adding the door but the IOS app did.

Only remaining problem is that while the door shows up on both my android and IOS phones it does not show on the website. Still says no doors there.


#17

Glad to hear you got it working. That was quite a quest.

There is no door showing in the web app because of the ambiguity between the generic particle account and Garadget specific account, both sharing the same login email. I two exist, then generic account gets picked up by the authentication code in the web app first, while the door is in the Garadget specific account.

This is not a frequent scenario, but I shall resolve it. I’m getting the “account type selector” for web app on my short list so this ambiguity is resolved for good. If you prefer not to wait, you can register a new account in the native app using the fresh email address and move Garadget to it in the process.


#18

I am so thrilled with this product. I love this damn thing. Thanks again for helping me.