Can't connect Garadget to Google Home

Google Home had been telling me that Garadget was offline for a while, so I removed Garadget from Google Home, with the intention of immediately reinstalling, assuming this would fix the problem of an old password or something.

Since removing it, I cannot add Garadget back to Google Home. I have tried on two separate occasions now, separated by a week or more.

When I go into Google Home, I go to add a device that works with Home. I select Garadget, put in my login info, and I hit Authorize. Then the screen blanks and returns me to the “Authorize Google” Home screen where I can enter a username and password. I don’t get told there was a failure. I don’t get told the username or password was wrong. I’ve checked the password I’m putting in more than once. I’m at a loss as to what is actually going on.

1 Like

Same issue with me. I get a Google Home prompt stating my Garadget is linked and successfully authorized but the device won’t show up in Google Home. Multiple tries with same result.

1 Like

I have had the same problem for 2 years and was hoping someone would post a solution :cry: