Can't connect with Particle


#1

I didn’t realize I needed to wait to set up a Particle account until after I hat the Garadget registered. I set up the Particle account to start integration with IFTTT. But now they don’t recognize each other. What can I do?


#2

The setup steps in the apps create a Particle account within Garadget’s organization. There is no need to separately register another Particle account.

If you have multiple accounts, you can move Garadget from one to another by repeating the device setup steps in the target account.


#3

The problem is I only have one Particle account and my Garadget does not show up on it. It says I don’t have any devices connected at all.


#4

If that is the account you created from Garadget app then log into the account and click on “add door” to setup your Garadget and associate it with the account. If that’s the regular Particle account then register a separate Garadget specific account.


#5

I did the same thing. Particle won’t let me sign in with my Garadget account. It will let me sign in with my original Particle account but it can’t see Garadget. Can I change the password on Particle to match Garadget? Will that work?


#6

@vtoshach,
I’m sure you can change the password but I doubt that will “merge” the two accounts.
I brought up the shared Particle/Garadget account issue in Particle forum but there is no official solution yet.

One of the challenges is that in order to push garage notifications, I receive the firehouse of events from all Garadgets via Particle platform. If Garadget is not associated with Garadget specific account then there is no way for Particle to know that they should include the events from that device in the stream that I’m handling.

One of the ideas for future is to abandon organization mode and handle events from each Garadget using webhooks configured in each individual Particle account. Please stay tuned for the updates.


#7

That will be good. I tried setting up a second account with Garadget, using a new email and password and I was still not able to login to Particle with the new account. Is there a lag when the Particle account is set up?


#8

Are you trying to login into Particle with the account you created in Garadget’s client software?
It’s mixed bag: with Garadget specific account I’m able to login into the dashboard but not to the online builder.

BTW: you can move your Garadget to your plain Particle account and use something like IFTTT to handle notifications. You’ll still be able to monitor and control your unit as well as enjoy location based notifications using the official clients.


#9

The device was very easy to install once I figured out the wires. You might want to add that to your instructions about where to place the wires and how they don’t matter. The other thing was the micro USB cable. You need a minimum of 6ft for most, I think. We managed with a piggy back extension. It works great.

The biggest problem I continue to have is not able to link to particle. I’ve tried just about anything and it doesn’t recognize my Garadget login. This is a big problem as I really wanted to use the IOS location feature.

Other then that, I am very happy with the product. It looks so simple but yet extremely effective and very easy to install (minus the wire confusion).


#10

@vtoshach, Thanks for your feedback! It helps to improve Garadget and prioritize the work on new features.
If you have a moment, please post the details/pics of your setup.


#11

How do you move it? I can’t set up IFTTT because Particle doesn’t see my device. And trust me, I’ve tried EVERYTHING.


#12

To move Garadget you can use Particle’s Tinker mobile app and claim the Device while logged into your generic Particle account.


#13

Hi, I couldn’t login with the account I used to login to garadget.com with, so I setup a seperate account on Particle and tried using the Particle app on iOS to move it to that account so I can use IFTTT. It lets me get most of the way through the setup, but it fails on the last step when it tries to claim ownership. Any hints for me?


#14

@peteinau, @vtoshach I did some experimenting and here’s more info on IFTTT integration. Hopefully this helps.