Daylight Savings

app-features
client-apps
time-zones
Tags: #<Tag:0x00007fad6fd5e5e8> #<Tag:0x00007fad6fd5e4a8> #<Tag:0x00007fad6fd5ddf0>

#1

How can I set the device to adjust for DST? I’m in PST and Daylight Savings has kicked in. But I’m getting alerts even right now for garage door opened between 10pm-7am but it’s 7:48am. After 8am, the alerts stop, so looks like it hasn’t adjusted for DST.


#2

Are you on PDT right now?


#3

Yes, switched to PDT on Sunday.


#4

The time switch is programmed into the firmware, In fact that was one of the most challenging part of implementation because it had to take into account all possible regional rules. Given the complexity, there’s also a higher opportunity for error.

If you selected following option in the timezone selector:

          <option value="10112-8.00,20032-7.00">(GMT-08:00 +DST) Pacific Time (US &amp; Canada)</option>

Then the switch to from GMT-8 to GMT-7 should have been on the second Sunday in March at 2am. (20032-7.00 part of value).

See if resetting the unit by pressing “R” button activates the change. Another thing to try is to change time zone to some other and then back to Pacific. If nothing else works there’s always Arizona with permanent GMT-7.

Please let me know though what worked if anything.


#5

That might be my problem :slight_smile: I can’t find a Time Zone selector.


#6

It’s in the alerts screen at the end of the section containing the night alert setting.


#7

Don’t know how I missed that :slight_smile: However I had it set right and I hit the R button and set the alerts to 10am and opened it at 9:57am and still go the alert.


#8

This is first report of the timezone/DST related issue. I’ll do some more testing on that.
Meanwhile see if Arizona TZ setting takes care of your immediate issue.


#9

On the other hand, you set alert to end at 10am and triggered event at 9:57am (while it was active) so that sounds like expected behavior.


#10

Good catch, I was making the change to quickly. I tried again just now and no alerts, looks like the R button fixed it.

Thanks for the QUICK responses and LOVING the device. THANK YOU!!!