Garadget won't enter setup after changing router


#1

I’ve recently had to change wifi and now I cannot setup the my garadget.

Here are some of the methods I tried

  1. connecting via wifi through 2 different android mobile device. Would put garadget to listening mode (blue blinking) and it will show PHOTO-VABA. Try to connect to wireless and it failed.
  2. Tried setting up via USB though CLI and still fail. CLI will detect but when you click yes to setup device it just skips. Sample screenshot below. (note also tried particle setup wifi with same results
  3. I tried entering DFU mode by holding M+R->M -> and then yellow blinking light will not appear even after holding it for 1 min.

Any ideas how to get pass this?


#2

@edtan,

  1. Please try connecting your mobile device to PHOTON-XXXX and request http://192.168.0.1/device-id
    Do you receive the response?

  2. With Particle CLI, do you get response to “particle identify” call?


#3

Yes it does.

it shows
"Your device id is 3f… (PM’d you the device ID)
Your system firmware version is 0.5.1"

Surprisingly firmware is pretty old and has not updated.


#4

If you are able to request the device IDs then all the basic elements of communication is there in both cases (WiFi & USB). With WiFi setup, please make sure that you start out with Internet connected phone and only reconnect it to PHOTON-XXXX when instructed by app. If you have Garadget still mounted on the opener, please try taking it down by removing M4 screw holding it to the opener. Getting it further away from opener’s metal sheet should improve the signal.

While in USB setup: The screenshot says “I have detected a P1 connected via USB” and that what should be set up, there is no need to look for other Photons via computer’s WiFi.

Re. firmware: I can supply latest binaries or update over the air when you get your Garadget online.


#5

I’ve just connected my old router to get it back connected. You could try an OTA and see what you can do.

With regards to the USB setup, I totally agree with you that there is no need to look for other photos via computer wifi, but as you can see in the screenshot, I’ve replied ‘Y’ and it goes automatically to the wifi setup.

The same applies to the wifi setup that even if you replied ‘Y’, it immediately exits the setup instead of logging in.

The screenshot I shared with you is probably 1 out of the different 20 combination I tried with no success. I have already done a USB setup a few months before with success so I’m not sure why it is not working now.


#6

Now you’re at 1.20. Among other things now you can use Garadget’s web interface to configure WiFi connection. For that put Garadget in listening mode, connect to PHOTON-XXXX from any WiFi enabled device and navigate browser to http://192.168.0.1/

There you’ll see the option to connect to access point of your choosing.


#7

Great. I was able to set it up via the web interface.

Thanks for the help.