Have been booted off app, says credentials are invalid!

I have not logged into Garadget for a few days. Tried just now and I cannot get logged in. Says credentials are invalid. I use Lastpass, so I know my password is correct.

SO it told to create a new account. Tried that. Said there was already a customer with that email. Yeah, ME!

So WTH? I was able to get into the forum here. But it won’t let me into the App. So I cannot control ny garage door nor get any notifications.


The community board and your Garadget app use separate accounts.
I’ll initiate a password reset for your Garadget account using the form at: https://www.garadget.com/my/forgot.php

Please PM me if you still unable to log into your existing account after that.

That fixed it. Thank you!

1 Like

I have a similar issue, except it is not a problem with the community password versus the unit password. It is a problem with the Garadget Refresh Service in the openHAB binding.

I can log in fine using the mobile app, but when I try to get connected via openHAB, it does not accept the credentials matching those correctly working on the app.

I tried restarting openHAB and restarting the binding, to no avail.

Debug log (username and password masked):

2020-04-04 18:21:46.051 [TRACE] [binding.garadget.internal.Connection] - sendCommand: funcName=createToken

2020-04-04 18:21:46.058 [TRACE] [binding.garadget.internal.Connection] - content='grant_type=password&username=xxxxxxxx&password=xxxxxxxxp&expires_in=0', contentType='application/x-www-form-urlencoded'

2020-04-04 18:21:46.062 [DEBUG] [binding.garadget.internal.Connection] - About to execute 'https://api.particle.io/oauth/token'

2020-04-04 18:21:46.590 [DEBUG] [binding.garadget.internal.Connection] - Method failed: HTTP/1.1 400 Bad Request

2020-04-04 18:21:46.592 [DEBUG] [binding.garadget.internal.Connection] - Body of response: {"error":"invalid_grant","error_description":"User credentials are invalid"}

2020-04-04 18:21:46.594 [TRACE] [binding.garadget.internal.Connection] - Processing login: statusCode=400, responseBody={"error":"invalid_grant","error_description":"User credentials are invalid"}

2020-04-04 18:21:47.221 [TRACE] [ng.garadget.internal.GaradgetBinding] - Polling Garadget devices

2020-04-04 18:21:47.224 [TRACE] [binding.garadget.internal.Connection] - sendCommand: funcName=getDevices

2020-04-04 18:21:47.227 [ERROR] [b.core.service.AbstractActiveService] - Error while executing background thread Garadget Refresh Service

java.lang.NullPointerException: null

	at org.openhab.binding.garadget.internal.Connection.sendCommand(Connection.java:229) ~[?:?]

	at org.openhab.binding.garadget.internal.Connection.sendCommand(Connection.java:186) ~[?:?]

	at org.openhab.binding.garadget.internal.Connection.getDevices(Connection.java:154) ~[?:?]

	at org.openhab.binding.garadget.internal.GaradgetBinding.execute(GaradgetBinding.java:204) ~[?:?]

	at org.openhab.core.binding.AbstractActiveBinding$BindingActiveService.execute(AbstractActiveBinding.java:146) ~[bundleFile:?]

	at org.openhab.core.service.AbstractActiveService$RefreshThread.run(AbstractActiveService.java:169) [bundleFile:?]

Since you can login in the app, but not in the integration, it’s likely to do with the way integration obtains the authorization token. The issue may be related to what is discussed here. I’m pinging the community contributor maintaining the integration (@watou).

1 Like

Alternatively, consider using a local OpenHAB MQTT link with Garadget as discussed here.

1 Like

I was part of that MQTT discussion (as harpo3), but thanks for pointing to it.

I have the same issue as @lpcornel in OH and can not sign in via the garadget iOS App after having signed off. Even resetting password does not work (user not found).
Web interface however works fine.

Your issue is a bit different because it is not related to Home Assistant. It is likely due to the use of the discontinued app. Please uninstall iOS app on your phone and install new version from the app store. In initial screen select “existing account” and login with your old password.

@garadget, thanks. Wasn’t aware of the new app.
OpenHAB problem still remains but is addressed with the respective community as well.

1 Like

Same here. App no longer accepts login credentials but I was able to log into the browser-based cloud service with the same credentials.

If I try reset passwd with app, it tells me there is no such user.

Don’t know if this is related but when I tried to log into community with google, it gave me a time-sync error.


Sorry. I should have read all of the posts. Getting the new app fixed this for me.