MQTT support

Tags: #<Tag:0x00007f0d90381270> #<Tag:0x00007f0d903810e0> #<Tag:0x00007f0d90380fa0>

Thank you for this response. That would explain it!

The firmware 1.2 is absolutely using the door name after connection. The EASIEST way around this is to first name your garaget door the name you want to use for your topic name. DO NOT have spaces in the door name. Then when you setup MQTT locally set your topic name to the same name as the door. It will all work.

If you have already done this. Once initially connected to a MQTT broker as you have found out you will end up with two topics. One of the topic name set locally in the garadget and one for door name. The topic you will want to use to control your garadget via the broker is the Door Name one…even if it has a space…it will work. I hope that all made sense. If I had the knowledge to suggest a change to the code I would…but I don’t. (Or you can go back and change your door name to match your topic name)

@garadget pointed us in the correction direction here:

Anyone qualified to get us to firmware 1.3?

Thank you for this, this was driving me nuts! im new to MQTT so spend 5 hours figuring out the topic kept changing.

So I have this working perfectly with HA, MQTT and Node Red. I have Node Red looking after all the sensor info and polling of the “state”. HA just issues the commands for Open or Close.

The changes is the “switch” and “change” nodes clean up some of the formatting. e.g. “m” is shown Minutes, all data is exported to sensors for HA. Using the RPE node to clear up unnecessary updates

image

image

I don’t use a command for Stop, by leaving the payload as empty. HA removes the option, so it can only go completely open or closed. Works perfectly exported to Homekit.

1 Like

This is looking great and worthy of a separate topic.
If you have some time to share your project a more detailed how-to would be much appreciated.

Done: Garadget, MQTT, Node-RED, Home Assistant, Homekit (or any other voice assistant with HA)

Awesome, thanks!