New installation - can't connect to Garadget


#1

Hello all,

I recently purchased two Garadgets and am trying to get them set up. It seems like I followed the directions correctly, but can’t seem to get connected to either Garadget to add them to my account. I’ve tried the Android app as well as the web app (on a Mac and an iPad) and can’t seem to get it to work.

When I turn on the Garagets, they blink blue as expected. For Android, the app says to choose the Garadget and the Photon WiFi network appears in the list. When I select it, however, the app brings up an error that reads “Please try running setup again after resetting your Garadget and putting it back in blinking blue listen mode if needed.” On the Web, it continues to say “Waiting for WiFi connection with Garadget” even though I’ve successfully switched to the temporary Photon network.

Any suggestions? I feel like I must be doing something wrong since the behavior is the same with both Garadgets.

Thanks,
Tad


#2

Tad,
Apologies for the difficulties you experience with the setup. It’s unlikely that you’ve received two faulty units.
Do you already have them installed in your garage or still have them on your desk? I’m asking because sometimes opener’s metal plate interferes with the weak signal emitted during the setup.


#3

My thoughts exactly… I do not have them installed yet; they were within a couple feet of the devices I was trying to use to get them set up. I was successfully joined to the WiFi network, had an assigned IP address (I’m pretty sure it was 192.168.0.2?) and was able to ping the Garadget (192.168.0.1) with no dropped packets and quick ping times.

If there’s a way I can configure them via USB, I’m okay with that – I’m very comfortable around a command line.


#4

USB is always an option: please see this post for the instructions. I’m around if you get stuck.


#5

Thanks for pointing me there! I was able to successfully add one of the two Garagets to my account.

The second one, however, gives the following:

$ ./particle identify

! serial: Serial timed out

Any idea how I can get past that?


#6

Do you see the serial port in device manager added when you plug the device?


#7

I’m on a Mac, but the device does appear in /dev.

crw-rw-rw- 1 root wheel 21, 4 Jan 17 23:06 tty.usbmodem1411
crw-rw-rw- 1 root wheel 21, 5 Jan 17 23:06 cu.usbmodem1411


#8

Still times out? Try a full reset (hold M button for about 10 seconds until a burst of quick blue blinks).
Maybe with a different micro-USB cable? If that doesn’t resolve it, PM me your order details and I’ll arrange a replacement.


#9

I did the reset and got a little closer… Was able to make it up to adding the device id.

Claiming device [redacted]
Failed to claim device, server said: Not a customer of product 8


#10

Please PM me the device ID, I’ll check on the server. Either there’s something with the firmware (we can re-flash) or your account is not under Garadget product (we can re-create).


#11

Hi, I have the same issue, I have been trying for the ast 2 nights to get 2 units set up. I am not very computer savvy so this is proving very difficult for me. I seriously need a hand.
Thanks, Hendre


#12

Hi, Hendre.
Of course. Please send me a PM (personal message) with the device ID.
If you don’t know it, I’ll guide you through the process of getting it.


#14

Having trouble connecting device. Won’t verify device ownership. I’ve reset device at least 10 times. Not sure if I’m in the right forum but can’t find any other one.


#15

Peter,
This is the right forum and we’ll get this sorted out.
What is the LED indications that you get in the process? Do you get bast green blinks to the cyan blinks and then to slow cyan pulsing?


#16

I had the same issue (both with Android and Web).
The USB setup worked for me so I’m good now but thought folks should know.

Thanks,


#17

Thanks for your report, Ian!