New Router tried all troubleshooting still not working

I have scoured this community and followed the troubleshooting from the website and still can’t get my device to connect. I haven’t used the device in at least 9 months but wanted to start using it again (only stopped using because it seemed to conflict with my regular remote door openers). Since then I have installed a new wifi router and I see that there is a new app (which I did download). I used the embedded web interface to connect it to my network which seemed to work because I have the slow blinking cyan light. Then I went online to “claim device”. I entered the device ID and clicked “claim device” and nothing happens. (I even right clicked the box in an attempt to open the link in another window and it does not even show up as a link). Then I also tried running the set up on the app and every time it comes up “setup failed” and give me a red box to start troubleshooting or checking the community forum. I even logged into my router to make sure my wifi is running on 20 channel width. At this point I have exhausted every troubleshooting possibility I can find. Any ideas where to go from here?

Please PM your device ID if you still experience the issue. Some devices may get quarantined from the fleet if they inactive for very long time. This could be the case there.