Not registering device

I have had a garadget for a couple of years now and a few months ago the usb connection broke.
I left it on my office desk until now and have just come back to try to recover it.
I have powered it through the extension port and all worked well until I tried to connect it to the internet.
The set up process works perfectly except that it says it needs to change ownership of the device. After this it goes through the setup and connects to my home wifi but then says it is verifying ownership.
After a fairly lengthy wait it then says Oops! and does not register the device so the next time I open the app it cannot find it so I cannot use the app to do anything.
The device is correctly connected to my wifi but not to the app?

From what you describe it sounds like you are using the discontinued version of the mobile app. Please uninstall it and reinstall the current version from the app store. When presented with the registration form, switch to the login form by clicking on “already have account” link.

Hi Denis
Yes, I have already tried that.
I tried again but the result is still the same.
I was wondering if deleting my user account and then my re-adding it would help because it seems to happen after all the local connection process is complete and when trying to check the device is connected to the server. The failure message comes up and it tells me to troubleshoot/Check Community or use the help system.
After waiting for several minutes and coming back into the application it seems to be registered and working again although I have not yet reconnected to the actual door opener.

Please do not attempt to delete my user account.

Thank you
Colin Brierley

Thanks for the update. Glad to hear that your Garadget is back in business.