Setup Problems - can't connect to server?


#1

I recent got 3 Garadgets! I was really having one heck of a time getting any of them setup using my Android…nor an iPhone. On Android or iPhone it just wouldn’t connect to the Garadget’s wifi no matter what I did. Sometimes it would “almost work” in that I would actually get to the screen where I could choose my home’s wifi…but after that nothing ever showed up. Eventually I gave up on all that and started in with the USB install via Particle. That wasn’t going the greatest either…until it did! I created a new account on garadget AND particle and I was able to get two of my units up and running that way! However…the 3rd. Doing the exact same process I can’t. I do the following

particle login
particle identify
particle setup wifi

I can setup my wifi and after that step I get fast flashing cyan. When I try to do

particle device add {the device id from the identify above}

just like I did on the first two I get:

Failed to claim device, server said: [object Object]

My “guess” is that somehow this got assigned to one of my old accounts. Anyway I can get this guy back into my family?

I also was able to get the smartthings integration up and working!

Thanks!


#2

If you initiate “add door” process from the correct account, the process will reassign the device from any previous account (if any).

The fact that you struggled with all three units suggests that the issue is not likely with the hardware. I’d try “add door” process while using a different router (friend’s or neighbor’s). If you experience exactly the same issue, we’ll explore other possibilities.

Congrats on SmartThings integration! @fuzzyligic did a great job there.


#3

Ok, tried at friends house and at work. When I get to the step to connect to the garadget WiFi the app just locks up, Garadget light keeps blinking blue (not cyan).

Same issue I was having at my house and why I eventually ended up going USB config route. I did not bring my laptop or install particle CLI at friends house to try.

I think my initial problem with the CLI was that I needed to create a new setup.garadget.com login which I found in this forum somewhere. AFTER I did that the CLI installs went fine…except for this one.

FWIW - I couldn’t get my Android (Droid Turbo 2 - Android 6.0) or iPhone (6s) to stay connected to any of the garadgets WiFi signals. Even if I held it on the phone.


#4

Please try the setup process through the web app. Through the process please keep your Garadget close to both your router and phone.

If that doesn’t help it, we’ll do the exchange.


#5

Tried webapp at friends house. Was able to get connected to wifi, I’m assuming because the lights went fast green then the Garadget was fast blinking cyan. Never got further than that.


#6

Since other units are connecting to the server, we can rule out the problem with the network.
You already have CLI installed, so you can try updating the encryption keys, but at this point we’re good for exchange anyway.


#7

I don’t mind trying that if it keeps us both from shipping back and forth.

So
particle login
particle identify
particle keys doctor {deviceID}

particle setup wifi
particle device add {deviceID}

or do I need to do the “particle keys new” and “particle keys new mykey” in the blank space?

Thanks.


#8

Let’s start form simplest (i.e. only device ID in parameters to keys doctor) method and if there’s a problem with it, then we can escalate further.


#9

Ok I did what I said above. Just the keys doctor. Had to install openssl. Keys doctor went well and said new keys generated, bla bla. aka no errors in the output and all looked good. Same light sequence. Green fast to then fast cyan. However I did notice a few yellow maybe orange quick flashes in there two. I believe there were two. They were quick and back to fast cyan.


#10

Fast cyan blinks means that it is successfully connected to WiFi, but can not reach or connect to the server.
Please PM me the ID of the unit in question, I’ll check if it logged in at any point.