Unable to connect to Wi-Fi network w/ WPA2-PSK [AES]

account-setup
device-setup
wifi
Tags: #<Tag:0x00007fe3b907d6a0> #<Tag:0x00007fe3b907d560> #<Tag:0x00007fe3b907d3f8>

#1

So here’s where I’m getting stuck:

The light will slow blink blue very shortly. As soon as the “Connecting to Wi-Fi network” displays, the light changes to the fast blinking green one (meaning it’s unable to connect to wifi?). It hangs up for a minute before saying:

Any ideas or suggestions? I’ve already gone through and tried all of the available security settings on the router and all the troubleshooting for the Garadget. Not sure if I just have a faulty unit.


#2

Green blinking LED indicates that the unit is unable to connect to WiFi router. Most obvious reason is incorrect WiFi password. Please verify it by forgetting the WiFi network in your phone’s settings and then trying to re-connect with the the credentials you give to Garadget.


#3

Thanks, tried and still no luck. I even changed the router password just to make sure. Need more information on my end?


#4

Few other things I’d try:

  • see if removing apostrophe from the SSID makes any difference
  • try setting up on friend’s or neighbor’s network to narrow down issue to either router or device

#5

NICE! Got rid of the apostrophe, works like a champ, thanks Denis!!


#6

Programmer’s intuition… Some code in Particle’s system not escaping the string as it should.
Thanks for your patience with this. I’ll add the note to the troubleshooting guide.


#7

The quick support is huge, thanks a lot! And good luck moving forward, this is a fantastic device!