Web interface not working, can't configure MQTT

I have my Garadget working through the Android app, but I purchased it with the intent to control it via MQTT from Home Assistant.

The instructions for this are to configure MQTT settings via the web interface. The web interface is not responding on my device. I’ve even followed the instructions on how to re-flash the firmware and done so from the GitHub repository… with the same result.

It doesn’t matter if I try with the device reset on its own WiFi network via my phone’s web browser, or if I try when it’s joined to my home network. Multiple machines, multiple browsers, and no web page served up.

Since I can’t seem to find any MQTT configuration settings in the phone app, this is a problem for me.

What am I missing?

There are a couple things here, and the instructions are all over the place so I don’t blame you for not being able to get this going.

For starters: if Garaget and your Home Assistant are on the network and using the same IP address Class B or Class C (e.g. 192.168.x.x or 192.168.1.x) there really is no need to use MQTT unless that’s just your preference. For me, I have other interested automations (NodeRed) that I’m using, so having everything in MQTT makes it easier.

To add insult to injury, the Home Assistant documentation page is currently out of date (I’m personally working on it).

To get Garage working without MQTT using the Garage API follow these instructions:

  1. Follow the instructions on this page to setup the Garage device. If you have already setup the device and need to reset it, use the instructions to reset the device instead.
  2. Login into the web interface to verify the device is working.
  3. Next integrate Garaget with Home Assistant by editing the configuration file (configuration.yaml using the example block of code on the Garaget Home Assistant documentation page. Note that you have to copy the device_id from the Garaget web interface under “Settings” into the example configuration.yaml.
  4. Then reboot Home Assistant so that it picks up the Garaget device.
  5. Now add it to your Home Assistant user interface by adding an entity card using the entity_if of the Garaget device inside Home Assistant found under Configure -> Entities in the left hand menu.
  6. Save your Lovelace configuration and you should have at least a card for Opening/Closing the garage door.

Let me know if you still want to use MQTT.

Oh… and here is the Garadget MQTT thread,, and it really needs to be pulled into a single post as it is a bit confusing what actually works and doesn’t.

So… thank you for trying to help, but I have just now found the problem.

  1. I purchased a refurbished unit and it had not been reflashed before being shipped out again. Whatever the previous owner did to my unit, it trashed the web interface.

  2. On my first attempt at flashing it back to factory firmware, I did not notice a driver error on my desktop which was preventing the DFU from working properly (though I noticed no errors and it did reset some things back to defaults).

So I’ve fixed the driver error by reinstalling the ParticleCLI and now successfully reflashed the device to the v1.20 firmware.

The device firmware update docs I used:

The page with the link to the ParticleCLI for Windows:

1 Like

I can now confirm I have my device working on my bench, controlled via MQTT by Home Assistant. I can hear the relay click, I can see the laser pulse, and I can see the measurements change when I aim it against something near or far.

I look forward to connecting it up to my garage just as soon as it warms up a bit.


I’ve had a garadget for about a year and so far it’s been really good about connecting and staying connected. I had it hooked up via the API and home assistant to be able to turn it on with my Echo Auto. I wanted to switch to MQTT because there has been a couple instances where the device went down recently and in general I’d like to keep it working locally.

When I began to setup MQTT I faced this same issue, but so far haven’t gotten to a resolution . I believe I’ve followed same steps, checked drivers and am confident I’ve flashed the binaries properly. Before I flashed, I was only able to access the web interface locally from my Particle once, and that was before I reset all my configuration and reflashed.

The reason I got to reflashing is because the web interface was loading extremely slow, to the point where it was unusable. This is when I was able to connect to the network and see the interface… once. I’m truly surprised as using things like wled and esphome I haven’t see web interfaces load nearly as slow on these small computers. I have had the same behavior after reflashing so I’m beginning to think there’s something I’ve missed, given that others have gotten it working. Is there anything I might be able to do at this point? I can check with the phone I used to setup the Garadget and see if I can get it back onto having it working through the app. But on iPhone setup is not working at all. I get errors with being unable to connect to the network, but I was able to connect once. It’s strange and unexpected behavior.

First, it is my understanding that the web interface is only available at initial configuration, so it should be normal for that to disappear once you’ve set the device to join your local wifi network over its own ad-hoc ‘Photon’ network.

Second, assuming you’re using a Windows PC (because I’m not a Mac or Linux guy), you’re going to want to open the properties of the USB device (showed up as ‘P1’ on my system) and check the hardware tab. There should be three items - Control Interface, Serial, and USB Composite device. One of the three on my system showed an error. I don’t know how that resulted in a partial flash/reset without obvious errors, but presumably I missed something scrolling by on the DFU console screen.

If you have any such errors, it’s worth reinstalling ParticleCLI for Windows to try and resolve that driver issue, then reflash the firmware if your driver issue is resolved.

Beyond that, I can’t help much, that’s as far as I’ve gone because it’s as far as I needed to go.

1 Like

Thanks for your response! I’ll give it a go and let you know what I find! Hope to get MQTT working soon :smiley:

Somehow it’s still not working. I looked through my drivers in devmgmt.msc and couldn’t find much that said “error”, though I’ll look again in the morning (I’m flashing it in my garage). So far I found this tool Particle recommends called Zadig, but manually installing the driver through this program also didn’t fix the issue. Whenever I attempt to connect to the PHOTON-XXXX after flashing it, I can’t connect to it. Once I was able to connect to it and then I faced an issue where I couldn’t load though it did direct to this page… I’m pretty confused on what I might’ve setup incorrectly. I’ve reinstalled particle-cli a couple times and attempted to manually install the driver, but still no luck. I also can’t have anyone remotely fix the issue as it’s not even connecting ad-hoc atm :laughing:. At any rate I’m hoping to learn some things to be able to fix this issue! Thanks for your assistance; I appreciate it!

Hey @RandomUserID, I got everything working when I came back to it (no idea what happened but pulling it out of the garage and connecting to it seemed to work). After setting up MQTT on Home Assistant it works for a day and then I get this in the Mosquitto logs Socket error on client Garage, disconnecting. No idea what’s causing this as I didn’t have these issues when I just had it connected to the cloud (same wifi access point). Any idea what might be happening or how I can force a reconnect? I’ve lengthened the Garadget timeout to 300 seconds from 5 and still have the issue. Still learning MQTT but wondering if you have any advice before I create a new forum post?