3 doors, with multi users IFTTT or Tasker


#1

I’m enjoying my Garadget tremendously. I have 3 garage doors. Before I install the remaining two doors, I thought I’d ask if there is a way to get more detailed control over which garage door opens when my phone is in geo-fence.

I’ve set up a geo-fence with life 360 since my Samsung S7 edge geo abilities are unreliable. The door opens perfectly for me now.

Since I’m a multi-car/multi-door user, how do I ensure that the correct aradget opens.
For example:
I’m riding with my husband in his vehicle, when we enter the geo fence, the Garadget will open the bay for MY vehicle. I wouldn’t’ want my garage door to open at that time, as I’m not in my car. My car is safely parked inside the garage.

Is there a way to create a rule to control this with a more granular approach? Perhaps, a rule stating my door opens when I enter the geo fence AND I’m connected to MY cars Bluetooth? I’m not a Tasker guru, and don’t know if this is the best approach. I’m open to ANY help I can get, as I love my Garadgets and want to install the remaining two, but want granular control.

Thanks for considering my delima.


#2

Valerie,
I’m glad to hear you’re enjoying your Garadget setup.
With each IFTTT applet you select which door you want to control. You can setup separate IFTTT accounts for yourself and your wife and that should allow you to control different doors.

I hadn’t had experience with Tasket so can’t tell for sure, but you can always control individual garage doors by using any service capable of calling a specially formed URL as shown in Garadget’s early IFTTT implementation relying on Maker Channel.


#3

Thank you for this quick response.
I’m sure my original post was somewhat unclear as I rambled. How would I stop garadget from opening when I’m traveling in my husband’s vehicle?

My understanding is that once I enter the geo-fence, my garadget door would open, even though I’m not in my car and I’m not trying to park in MY garage bay. I wouldn’t want MY bay to open in the event I’m riding in our other car.

Please help - I’m still not certain I’ve articulated my problem well. I’m happy to provide more clarification if needed.


#4

Unfortunately the triggering app will have no way of knowing how you got home, unless the source of the location is something tied to the car. I saw IFTTT triggers for BMW and Tesla. There may be other car specific devices that can trigger the event.


#5

uggg. I’m not a guru in IFTTT triggers. I’ll go poke around and see if there is something available for Land Rover. If I could have geofence AND bluetooth = connected to my car, I think it would work. I’m just not sure how to make that two trigger event happen. Probably Tasker… which I don’t understand.


#6

@Vroom, I think I’ve got the basics of what you’re wanting figured out. I used to be a heavy Tasker user, but I’ve had to relearn a lot of it, lol. The below should help you with the basics of what you need. I only have one garage door, and currently only have this setup for our van that parks in said garage. Since you have two garages and two cars, my assumption is that you will just need to follow these steps for each garage/car. I’ve outlined the things you need, the basics of what happens, and then I break it down on how to setup each of those things.

Things you will need:
*Computer - it’s easiest to get your Garadget access token from here (via https://www.garadget.com/my/)
*IFTTT
*Tasker - yes, it’s a paid app. I paid for this many years ago when I first started using android. I don’t remember how much it costs, but it’s several dollars. I find it’s worth it.
*Tasker plugin “AutoRemote” - also a paid plugin. This one I had to buy yesterday for ~$3. Unfortunately the “Lite” version of this app truncates the messages it sends to 2 characters. If you shorten the message that AutoRemote sends, you might be able to get away with using the Lite version.

Order of events:
*I’m using IFTTT to detect location. If I enter my home location, then it uses Maker to send a message to AutoRemote
*Tasker watches for the message that AutoRemote sends, and if it’s connected to a specific bluetooth device, then it sends a command to the Garadget to open the door.

This is kind of a convoluted way of getting it done, and I REALLY hope that eventually IFTTT will be able to handle multiple THIS’s and THAT’s. But, until that day, we need several different apps/plugins talking to each other in order to get things done. Lol.

Steps to get it done:

  1. Download all the apps and plugins you’ll need. There are lots of “how to’s” for Tasker setup if you google them, so I won’t post that here. You shouldn’t need to do much though.
  2. Sign in to IFTTT and connect the maker webhooks channel https://ifttt.com/maker_webhooks. After that is connected, we will need the “key”. Go to “Documentation” from the webhooks channel, and it should be displayed at the top. It’s a fairly long string of characters. Copy this, or write it down somewhere, we’ll need it in the next step.
  3. Open AutoRemote. Several popups will display, letting you know some info about it, and asking if you want to see videos, etc. Feel free to look at all of this if you want. If not, tap on the ‘devices’ icon at the bottom (it looks like a phone). From there, tap the IFTTT icon (red, black and blue triangle icon). It will then ask you for your maker channel secret (the string from step 2). Add that here and tap ok. It will ask you to name the “device”. I just stuck with “IFTTT”. After this, it will tell you it’s going to generate a URL that can send a message for you to use in Maker. Tap OK, then OK again. At this point, a popup will display and ask you where you want to send the URL its generating. I selected “copy to clipboard”. You can also email it to yourself, etc. Either way, you’ll need that URL in next step. Now we’re done with AutoRemote.
  4. Back to IFTTT. Create a new applet. For the “this” we use location, then select when ‘you enter an area’. This will display your location, which you can edit. Hit the check mark once you’re done fine tuning the geo fence, then select “that”. For that, we want to use Maker, ‘make a web request’. Put the URL you got from AutoRemote into the URL field. The end of the URL should say message=MESSAGE_HERE. Change MESSAGE_HERE to whatever you want. I used message=Garadget_open. Leave everything else alone, and complete the applet.
  5. Open Garadget web access and get your device id, and access token. The device id can be found from the ‘settings’ page. To get the access token, you basically want to right click and select ‘inspect’, then go to the ‘network’ tab. You should see a bunch of messages for doorStatus? along with access_token. Copy or write the token down somewhere. We will need it for Tasker. The device id is also listed in the URL if you want to get it all from the same location.
  6. Open Tasker. I find it easiest to create the “Task” first. This is what we want taker to do (open the garage door). We’ll then create a “Profile” to handle everything else. So, go to Tasks, create a new task, name it whatever you want (I went with “Open Garage”). Tap the + button at the bottom, and select ‘Net’, then ‘HTTP Post’. Fill in the details for server:port, path, and data/file as per below (making sure to input your own device id and access token that we got in step 5):

Server:Port:
https://api.particle.io

Path:
/v1/devices/[myDeviceID]/setState?access_token=[myAccessToken]

Data / File:
arg=Open

Now tap the back button in the top left of the app, and back again. You should now see your task in the Tasks tab.
7. Now we need a Profile to perform this task. So go to the Profiles tab, tap the + button again, select Event->Plugin->AutoRemote->AutoRemote (again). Tap the pencil next to Configuration, tap Message Filter, and type in the message you setup in AutoRemote (from step 4). Again, I used Garadget_open. After that, just save everything and go back. It should ask you to assign a task. Select the task you created in step 6. Now, at this point, you basically have a location based system that will open the door for you. Since we ALSO want it to check bluetooth before opening the door, we need to add an additional context to the profile. So, back in the profiles tab, we want to long press on the autoremote profile we created, and tap Add->State->Net->BT Connected. Under the Name or Address fields, there are magnifying glasses. Tap eithert, and select the bluetooth device for whichever car you want, and then go back. So now the profile should show both AutoRemote (with our custom message) + BT Connected with whichever device you selected on the left, and it should show our task to open the garage.

Now you should be done for one garage and one car. To add additional garages and cars, you should only need to create a new task (step 6), using the device id for the other Garadget, and then create a new profile identical to our previous one, but make sure to select the bluetooth device of the other car.

Hopefully that all makes at least some sense, and is “newbie” friendly. Most of this stuff still doesn’t make sense to me, years later, lol!

Thank you for posting! I had wanted to do something like this for a while. Just using the location to open the door wasn’t what I wanted, since I’m not always driving a vehicle that needs to go in the garage (maybe I went for a walk or something, etc). Having the extra step of coming home AND being connected to a specific vehicle will greatly decrease the amount of times the garage opens when I don’t actually want it to :slight_smile:


#7

@MdMx, Thank you so much for this brilliantly documented, newbie friendly, and helpful solution. I had a long delay in attempting the solution as I had to replace my original garadget.

I was able to complete all of the steps. However, I can’t get the garadget to open. As a newbie, I’m not sure the best way to troubleshoot this. I went to IFTTT to verify the message is sent to AutoRemote. I verified that a log entry is received in AutoRemote, with my Garadget_open message. So, I’m thinking that IFTTT and AutoRemote functionality appear to be working. I’m unsure how to verify what’s going on with Tasker.

Would you mind giving me a little more of your brilliance, I think I’m close… so close. Any ideas?

Just for clarity, when you refer to “Maker” you are meaning Maker Webhook? Or is there yet another app/channel that I should be using.

I was sure to replace info where appropriate. Device ID, and Access Token. (access token was a very long string)?

Thanks for all that you’ve done for this solution.
V


#8

You’re too kind. Brilliance is a stretch, lol! When referring to maker, yes, the maker webhook channel is the right one.

I think you’re right. If IFTTT is sending the message to AutoRemote, there’s gotta be an issue between AutoRemote and Tasker, or just something wrong in Tasker.

Have you tried seeing if your Task itself is functioning? Within Tasker, tap on the ‘Tasks’ tab at the top, then select your open garage task. This would be what you did in step 6. There should be just the one line for HTTP Post. In the bottom left corner of the task, there should be a little play icon. If you tap that, it should run the task (the garadget should open). If it opens, that rules out the Task itself being the issue. If it doesn’t open, then there might be a random ghost/blank space in the url, or a random capitalization issue, or the access token is incorrect, etc.

If the Task itself isn’t the issue, then we’ll need to check the profile back in the Profiles tab. If you set it up like I did, where both the AutoRemote message + Bluetooth connected to whichever device you selected, you can test part of it rather easily. Tasker (while difficult to work with at times) does have some handy features. If you look at your profile while you’re in your car, connected to bluetooth, you should see the bluetooth portion of your profile turn the text green. So that would tell us that portion is working correctly. If not, make sure to recheck that the bluetooth name is correct.

If bluetooth checks out, you’ll have to check the AutoRemote portion of the profile. Unfortunately, that one isn’t quite as easy as the bluetooth one is to check. If you want to see the text highlight green (meaning it’s working), you’d have to trigger the message from IFTTT, which is a bit more of a hassle, and we’re already pretty sure that’s working correctly anyway. So, tap the AutoRemote portion of the profile, then tap the pencil next to Configuration, then tap Message Filter. This should display your Garadget_open message.Make sure there’s no blank spaces, or extra characters.

That’s the only things I can think of that would cause issues. You could also leave Tasker open the next time you get home (have your husband drive your car, or have him watch Tasker, for safety purposes :wink: ). You should see the bluetooth in green text, and then whenever IFTTT sends the message to AutoRemote, you should see the AutoRemote part of the profile turn green (at least momentarily). If that AutoRemote part of the profile isn’t working, I’m not too sure what else to check. Maybe the app permissions, notification access, or administrator privileges need to be checked as well. I don’t want to send you on a wild goose chase, because a lot of system settings menus are different from device to device, so if I tell you where that is on my phone, it might not be the same for you.

Keep me posted on how it works out :slight_smile:


#9

@MdMx, Oh brilliant one, thanks to your guidance, I found what I think is a typo in the “how to” instructions after following ideas.

Server:Port:
https://api.particle.io1 maybe should be https://api.particle.io ???

(I was getting an error message when I “played” the task. I removed the 1 and now, I don’t get an error message, and a little green dot displays next to the item.

I also checked the Bluetooth connection, all is well there with the green dot displaying when activated.

Garadget still won’t open. I think that my access_token keeps changing each time I access the web app.?. Any ideas about how to resolve this and get a static access_token? I read another thread, but it was way over my head with effective dates and other things I didn’t understand.

I’m soooo close (I hope)

Any thoughts are very much appreciated.


#10

Whoa, good catch. You’re absolutely right, that should be https://api.particle.io

As far as your access_token, I wouldn’t have thought that should change…but I just looked at mine, and mine has changed too. But I also just got home, and my garadget opened as it should, so I’m a little confused :confused:

Maybe @garadget can provide some insight into the access token part of it.


#11

There can be multiple valid tokens per account. When multiple users login to the account, each get their own.


#12

I’m hoping you can help me. I need to know which access_token I should be using when I have the following line, where access_token is always the same.

/v1/devices/DEVICE_IDXXXXXXXXXXXXXXX/setState?access_token=######xxxx##xxx#####x##xxx#000000000000000000x###xx###xx##

I’m a little confused because @MdMx solution appears to be working dandy even though his access_token changes. I’m hoping I have the correct access_token. I followed the very detailed instructions in this thread. I don’t have any error messages coming from tasker, the garage just won’t open. Yeeks. I feel like I’m so close to having this work.


#13

Any valid token should work for all of the commands. I’m not familiar with tasker, but I can recommend test-submitting the request manually before using it in the automated scenario. You can rely on one of the online form submitters for this.