App just opens and closes right away


#1

I have an Amazon Fire phone (Android). When I first installed the app, it worked perfectly. Now when I launch it, it just opens for a second then closes. I have tried uninstalling and reinstalling, no change.


#2

When you operate the door with the wall button, does the status reflect correctly in the Android app?
How about web app?


#3

The app used to open and notify me, but now nothing happens when I open or close the door.


#4

Please PM me the ID of your device, I’ll see if it stays connected.


#5

I had a similar issue with my iPhone. I have 2 doors on my account and when I tried to open the app it would crash (open and immediately close).

I was able to resolve the problem by doing the following:

  • I used a browser and went to the https://www.garadget.com/my/ site and looked at the settings on each door…
  • I noticed that the doors were set for different time zones.
  • I changed both doors to the same time zone
  • I also set all the alert settings the same for both doors.

This stopped the app from crashing. Hope this is helpful to others who may have the same issue.


#6

I’m having this issue on my iPhone 6s+ as well - The web app (and Home Assistant interface) works fine, but the iOS app closes right after it sees the garage door online.

It’s not actually closing, however, it’s just going to the background. When I double-click my home button, I see the app running, but when I select the app (or close it and re-open), it does the same thing.

I saw @matt 's suggestion, but I only have one door.


#7

@roddie, please PM me your device ID, I’ll check things out on my end.
At least once before, similar situation was caused by the invalid setting.


#8

Got your device ID. Using the web app, please go to notifications and set the correct time zone in night alert.
If not enabled, you may need to enable it temporarily and then disable again. Please report if this solves the iOS app issue.


#9

@garadget, I had already tried this - Just did it again, with the same results. The app still goes immediately to the background after it connects to the door. I’ve also tried uninstalling and reinstalling, as well as resetting my iPhone.

Thanks!


#10

Sorry, was looking at the different device.
In your case it’s the name. Please visit “Settings” page and assign the door a name.


#11

@garadget, it already had a name: “large door”

I just tried changing it to “Large Door” and “LargeDoor”, but I’m still having the issue.


App Door Animation
Lazer Adjustment
Cannot setup the device
#12

There are several more settings that got out of bounds.
ver=1.10|rdt=65535|mtt=6000|rlt=65535|rlp=65535|srr=255|srt=45|aev=65535|aot=65535|ans=0|ane=0|tzo=10112-6.00,20032-5.00|nme=LargeDoor

Please reset to defaults before setting back to your preferred values:

Scan Period = 1s
Sensor Reads = 3
Sensor Threshold = 15
Door Motion Time = 10s
Relay On Time = 0.3s
Relay Off Time = 1s

Also in alerts:

  • disable all state alerts
  • enable timeout alert and set timeout to 20min

This should restore a the valid values in settings.


#13

Denis,

That worked –

The odd thing is that the only settings I changed from all of those after installtion was the Sensor Threshold and Door Motion Time. All of the rest were already set that way out of the box.

A nice feature would be the ability to reset to default (or at least display the default value) on the settings page.

(also, “consecutive” is spelled incorrectly under Relay Off Time)

Thank you for your help!
Roddie


#14

Great suggestions, Roddie.
Thanks for your feedback! Fixed the spelling and got the rest on my todo list.