Can't get to garadget.com/my on Att uverse


#1

I can’t get to the communit page but cannot get to https://www.garadget.com/my/ to setup my device on my phone or pc.

Seems like some sort of issue with my ATT uverse. I can get to it on my phone when wifi is off. I have gone through all the normal troubleshooting. Tried different dns server and rebooted all my equipment but nothing changes. I get an error on the app trying to connect to the garadget but I think its because it can’t get to the internet via the wifi.

Any ideas on how to fix this. Looks like its a routing issue with att to me?


#2

To rule out network related issues you can try setting up your Garadget on friend’s or neighbor’s network as a test. Cellphone’s hot spot may also work. If that works out without issues then there’s network connectivity problem.

Please let me know the results of your experiment and we’ll continue troubleshooting the issue.


#3

Have tried on multiple connections through the android app and the web app. Just cant get it to connect.

The photon-xxxx network is there but nothing happens on the web app when i connect and on the android app i get that same error every time.


#4

When connected to the PHOTON-XXXX access point, do you receive the response in your browser when requesting following URL?

http://192.168.0.1/device-id


#5

A post was split to a new topic: Private Message: Device ID


#6

Zach,
I’ve got your device ID, thanks for the info. Your Garadget is not yet initialized.
Did you try to set it up using iOS or Android app?


#7

Dont have ios but have tried on android and web app.


#8

Can you please supply the screenshot of the Android setup process where you get stuck or receive the error message. Also, what are the LED indications on your Garadget at that time?


#9

Led is blinking blue.

New photo by Zach Scott

#10

Do you get to the part of the process where the app lists wireless networks in your area and asks for password for the one you select?


#11

Nope, on the web app it says connect to the wifi and has the flashing green circiles and then you connect and the circles go away but never goes past that.

On the android app. You hit ready and select the unit with the local network selected and you get that error. If you connect to the garadget first and then hit ready and select it you get the same message.


#12

Are you willing to try setting up using USB connection? If you need help, I can assist using a remote connection. Please let me know.


#13

I’ll give it a try my home automation setup is Home Assistant so don’t have any issue with command line stuff.


#14

I get this error when searching for a wifi network.

{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }

Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }
Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…
{ [Error: connect ECONNREFUSED 192.168.0.1:5609]
code: ‘ECONNREFUSED’,
errno: ‘ECONNREFUSED’,
syscall: ‘connect’,
address: ‘192.168.0.1’,
port: 5609 }

Then after i input the network manually i never connects. I get this.

Obtaining device information…

Obtaining device information…

Obtaining device information…

Obtaining device information…


#15

This post in Particle’s board suggests running this command while your device is connected via USB and in listening mode:

particle serial wifi


#16

Cool that looks to have worked. I will have to see if i can get it setup at home now. I don’t have any garage doors at work :slight_smile:


#17

Nicely done. Please let me know if you encounter any more difficulties.