Chamberlain Security 2+ System Workaround

chamberlain
security-2
Tags: #<Tag:0x00007fe3b72aa2b8> #<Tag:0x00007fe3b72aa178>

#1

Here is a way to use Garadget with Chamberlain Security 2+ openers. Such openers are incompatible with a contact output such as from a doorbell switch or Garadget (known as a ‘dry contact’ because there is no voltage provided by the doorbell switch or Garadget device), but there is an easy solution. This solution should apply to other openers that do not accept a dry contact input.

I purchased a new Chamberlain 3-button remote to overcome the fact that Chamberlain Security 2+ does not accept dry contact inputs. The remote does accept a dry contact input. Garadget supplies the dry contact input to the remote.

You can see in the sequence of photos that I soldered wires to the SW2 normally open terminals on the printed circuit board (you could use SW 1,2, or 4. SW3 is not recognized). I used a twisted pair from an old Cat 5 cable. I glued the wire to the PC board with hot glue so it would not flex and break off the connection. I could not find my small electronic soldering iron so I had to use a larger one and the soldering job is not very pretty. I set up Garadget according to instructions late one night, but when I went to bed apparently the server had not yet updated with my installation. There was a triangle with an exclamation mark superimposed over the garage door art. In the morning however the exclamation mark was gone and all seemed to be well on the workbench. I guess it just took some time at the server to update itself to this device. I physically installed everything in about 30 minutes. You can see the installation on the Chamberlain drive assembly in the photos.

I have enabled the Alexa app for Garadget and now have voice control over the garage door plus I can inquire about the status from any Alexa device in the house. I did not damage the new Chamberlain remote device so it can be used independently again someday just by clipping off the wires.

I highly recommend this solution to the problem of interfacing a dry contact output from Garadget with the Security 2+ system that Chamberlain has which does not recognize a dry contact. Whatever opener you have, if it will not accept a dry contact input such as from a doorbell switch, you can just buy one of their remote devices and parallel the output of Garadget with one of the push-button switches on the remote device.


#2

Dale,
Thanks for sharing!


#3

I have a question about how your system operated prior to doing this. Mine will open or close the garage door one time only each time I do the setup. I get all notifications as normal but the app and website will only allow me to open or close the garage door once and then only shows the door moving on the app but nothing actually happens to the door. Did you experience this same thing before doing this trick to the remote control?
Thanks in advance,
Dave


#4

Dave,
Did you implement the same work-around using a native remote as described here by Dale?


#5

Before I added the Garadget device my opener was just an out-of-the box Chamberlain myQ opener that I purchased at Lowes. I used the Chamberlain myQ app on my smart phone through my home WiFi network to check status, operate the door, etc. I added the Garadget device because I could then have voice control via Alexa, but used the described workaround to overcome the fact that my Chamberlain garage door controls do not recognize an open-close doorbell button type of input. I have had no problems with the entire system of Chamberlain myQ-Alexa-Garadget not working according to expectation and design.


#6

I have not tried this yet. I have an older model Craftsman manufactur date of 07/13. Says it’s a model 139.53918D so I don’t know if it’s worth the effort or not?

I have already tried to short the connection on the Garadget blue tab and that seems to work fine so I was curious if Dale was having the same issue as me before I open up my remote to try this. I have a soldering iron but not great at using it.


#7

Thanks for the reply Dale. I may break down and try your method just to see if it does the trick. I have tried everything else I can find with no luck over the past week.

Dave


#8

The issue you experience is likely relay sticking due to high current the opener sends through it. The workaround involving a native remote will also help with this situation. Usually though, this work around is used when opener does not support a simple push button console. Yours does, so you can choose the approach.


#9

I took apart my remote and disconnected the wires to start this fix. As I was reading I noticed that you had some words in blue here which I touched to look at what they were linking to. So I did a good bit of reading the relay links you added and found some info about setting the relay delay. So far the door has worked several cycles after setting the delay at its maximum of 5 seconds for one setting and one second for the other relay setting.

Hopefully this is the fix I needed but if it acts up over the next few days I’ll try the Dale method then.

Thanks to both of you for the help you provided here. This is truly people helping other people and is a testament to kindness towards others.
Take care,
Dave


#10

Great walkthrough and helpful photos, Dale. I’ve followed the steps you outline but I’m not getting any action from the remote. Any ideas?


#11

I’m not sure what brand of remote you are using. I used a Chamberlain 3-button remote and it was fairly clear where to make the connections. Make sure your connections go to the correct points on the back of the circuit board. My Chamberlain remote has three push buttons and any one of them can be used for this purpose. Make sure what you are connecting to is normally open and goes closed when you depress the push button. I had to use an ohmmeter and trace the path on the circuit board to make sure I was connecting to the correct points on the switch (each switch on my circuit board had four connections to the board so I had to be careful which pair I chose). I would also suggest inspecting the solder connections to make sure you have not bridged over to another connection or path on the circuit board inadvertently. I also suggest using a smaller diameter solid conductor that you might salvage from an old piece of ethernet cable. It looks like you have used some stranded speaker wire, and it is difficult to get a clean connection with stranded wire on a miniature circuit board.


#12

Matt,
My bet would be on these connections:

image

Here’s the plan:

  1. Carefully remove the wiring from your previous attempt
  2. Confirm if the board is still functional by clicking the button on the other side and making sure the opener responds
  3. Using a piece of conductor short two spots highlighted in above picture and make sure the opener responds the same way as when you pressed the button
  4. Per @Dale use a smaller diameter solid wire or multi-thread wire from old USB cable to attach to the highlighted points. Don’t be shy about amount of flux.

#13

Perfect. It worked using the points suggested! Alexa-enabled. One garage down, one to go. Thank you!