Not responding to IFTTT trigger (after three months flawless operation)


#1

IFTTT is set to trigger open and close door at specific times. All was well until five days ago.

On IFTTT settings/configure page; message – Failed loading options for “Which door?”. (error code 500)

IFTTT Activity log - Action failure message “There was a problem with the Garadget service.”

Last ran successfully on June 18

I’m using only one door. Garadget is online, all appears normal. Signal strength “excellent, -52 db. Correctly reports door status. Reset did not fix.

I read an existing topic that suggested “re-authorizing” my Garadget account with IFTTT. Please tell me how to do that – I don’t see how/where to do so in IFTTT. Any other possible fixes? Thank you.


#2

Bob,
You can re-authorize your Garadget account with IFTTT with in your account page for the service. Please let me know if this doesn’t address the issue.


#3

Thanks you for your reply. But after several attempts, I still can’t accomplish the objective. Clicking on the hotlink didn’t help.
Can you please me more specific - maybe step-by-step?
Thank you, Bob G


#4

I tried to connect the applet and login using this link. I get this error: “client_id is a required parameter”


#5

Was that for “Edit Connection” link? I just tested that with my account and it appears to be working.
Please see if disconnecting and re-connecting fixes the issue.


#6

This was when you authorize garadget. I logged into IFTTT with my Google account. Then tried authorizing a third party (garadget)


#8


#9

If you try that on desktop computer so it’s easier to see the page URL, does it look something like this:

https://www.garadget.com/api/oauth/authorize?client_id=garadget-ifttt-3675&redirect_uri=https%3A%2F%2Fifttt.com%2Fchannels%2Fgaradget%2Fauthorize&response_type=code&scope=ifttt&state=xxxlong-string-here

Note the presence of client_id parameter there.


#10

Yeah it does have that parameter. I’m not sure why I can’t login. I’m using the same password. Whats the web url ? Let me try there.

https://www.garadget.com/api/oauth/authorize?client_id=garadget-ifttt-3675&redirect_uri=https%3A%2F%2Fifttt.com%2Fchannels%2Fgaradget%2Fauthorize&response_type=code&scope=ifttt&state=(removed)


#11

Can you disconnect the service and then re-connect it instead of editing connection?


#12

I was able to login to garadget.com/my/login/php with (removed)@gmail.com and my password. Not sure why IFTTT wont work with the same password.


#13

I figured it out. If you enter a wrong password once. You have to logout of IFTTT and try connecting again with the correct password.


#14

For me, this issue resolved itself spontaneously and Garadget\IFTTT began communicating again yesterday, June 24. (??) So, it was not working for five days, June 19 through June 23, but now is fine again. ??


#15

Hi Denis,

I’ve been away the past two days and without email.

However, this issue resolved itself spontaneously and Garadget\IFTTT began working normally again yesterday, June 24. ?? So, it was not working for five days, June 19 through June 23, but now is fine again. ??

BTW, I see that I’ve received several emails that were replies to mhyguyen, but sent to gorm@cox.net. Don’t know if that was intentional.

Bob Gormley


#16

I also had IFTTT and Alexa stop working at the same time yesterday. I’ve had that problem with the Alexa widget before and knew to disable and re-enable to get it working again. First time I needed to reauthorize IFTTT though. Anyway we can avoid that problem in the future? Also, can we avoid needing to relogin to the Garadget App all the time?

Thanks.


#17

Thank you for your feedback, Jim.
The authentication and tokens are handled by the Particle (cloud service provider).
I’ll keep looking into this issue to make improvements.


#18

Since the 1.2 firmware update, IFTTT is again not working. The only applet I use is “Open Garage on Arrival.” I attempted to reauthorize IFTTT but the applet can find my door. Keeps reading “Loading…” I deleted the app and when I attempt to reinstall, I get an error message “We can’t access your service” so reinstallation is impossible. Now what?


#19

I forgot to point out that the Garadget app and Alexa app work just fine.


#20

It’s unlikely that the issue has to do with the firmware update because IFTTT has no way of knowing about it and there was no change in server API that it uses.

Please try to re-authorize the service by clicking [edit connection] and re-submitting the credentials.


#21

That worked. Thanks. I could swear that I’d already tried the reauthorizing thing before posting…