FYI - found why my wifi setup connection always failed

signal
wireless
antenna
wifi
device-setup
Tags: #<Tag:0x00007fad6fc6e1b0> #<Tag:0x00007fad6fc6e070> #<Tag:0x00007fad6fc6df30> #<Tag:0x00007fad6fc6ddf0> #<Tag:0x00007fad6fc6dcb0>

#1

I had my steady blue flashing light and my app would find the PHOTON-XXXX ssid. However, they would never connect. Tried different many attempts, app reinstalls and using different Android mobile device - all failed.

It turns out the issue is my Netgear router’s wifi mode was not compatible with the device ONLY DURING SETUP. The router is set to 2.4GHz “b/g/n” mode (its a model WNDR4500).

Solution:
I used my simple ATT wireless router and the setup went perfectly. During the setup I configured the device to my normal Netgear “2.4Ghz b/g/n” wifi manually and it connected perfectly and has continued to work just fine since.

For whatever reason, the initial device setup process could see my netgear wifi SSID but was never able to complete setup using its native setup process. By using a different (simple) wifi router/ssid for initial setup and then manually pointing it to my Netgear wifi/SSID all was fine.


#2

@bquintrell, I’m glad to hear your connection issue got resolved. I’m not entirely sure about the contribution of the additional router though.

Here’s what’s going on during the device setup:

  1. You can enter device setup immediately after registering the account or from the existing account. In either case you are first identified with the Particle cloud.
  2. Your mobile device, while still connected to the Internet, requests a secret string (claim code) from Particle cloud.
  3. When instructed, you re-connect your mobile device from your regular WiFi connection to temporarily open hot spot created by Garadget.
  4. You pick your the name of your home network from the list of networks reported by Garadget and specify the login credentials. The credentials as well as claim code are sent to Garadget.
  5. Garadget shuts down its temporary WiFi hot spot and attempts connection to your home network using provided credentials and if successful, connects to the Particle cloud.
  6. Garadget presents the claim code to Particle cloud proving that the owner of the account is in physical possession of the hardware. Particle cloud assigns ownership of the device to the account.

If I understand correctly, the problem was at the step #3 which is a connection between your mobile device and Garadget. The router is not participating in the process until step #5. Failure at the router would result in Garadget not being able to complete steps #5 or #6. That would manifest itself as fast blinking green LED, fast blinking cyan or device not listed in the account.

There still may be some explanation for the router affecting the setup such radio interference from the router somehow affecting the communication between Garadget and your mobile device…


#3

my garadget will not connect with my home network. I tried even creating a hotspot with my phone. that too only 2 feet away wouldn’t connect and would give me the Ooop error. I have not idea why the garadget will not connect and why the red laser light never came on either.


#4

The laser does not activate until there’s a WiFi and server connection. No worries though, we’ll sort it out one way or the other. Please try setting up the device using the web interface and let me know how it goes.


#5

I tried the web interface. when I get to the same spot it recognizes my network and when I put in password to connect it starts blinking fast green with occasional red. then my phone says no door.


#6

Can you confirm the credentials you supply to Garadget by “forgetting” the WiFi in you phone’s settings and then re-connecting again?


#7

I forgot the 2 garadget wifi networks that were there. then reopened the web interface and same thing happened again


#8

I was referring to your phone’s connection to your home WiFi network.
In the process of the Garadget setup you select your home WiFi network and specify the password.
One of the reason for your unit’s inability to establish the connection (fast blinking green LED) may be the wrong connection credentials. One way to verify that is to disconnect your phone from the home network (forget it in settings) and re-connect again. If successful, then the credentials are correct.

Other things to check:

  • make sure that 2.4GB band is enabled in your wireless router
  • make sure that WPA is selected as wireless security
  • if available, make sure that the beamforming feature is temporarily turned off

#9

It has a beamforming feature. I have nighthawk X4 AC2350 Dual Band wifi router. I still can’t seem to connect. I’m trying to figure out how to turn off the beamforming feature


#10

Please check if this is of any help. If your router’s admin is different please post the screenshot when you locate the setting.


#11

the router is set up for 2.4. I already turned off the 5ghz


#12

The 5.0GHz band doesn’t have to be off, what important is that 2.4GHz band remains on.
Any luck temporarily deactivating beamforming?


#13

I am having a hard time finding where I can turn off beamforming


#14

Found it. I turned it off and will try again


#15

no luck. when I go to switch over to connecting to my network it drops me after I click next.


#16

Were you able to confirm the WiFi connection credentials for 2.4GHz access point by re-connecting some other device?


#17

yes its set to 2.4ghz.


#18

Yes, I understand that 2.4GHz access point is enabled. Earlier I suggested to verify that the password you specify during the Garadget setup is correct by re-connecting some other device with the same credentials and make sure that router allows the connection.


#19

Oh sorry. Yes I’ve triple cheeked the password. I’ve even checked when I went into my router.


#22

At this point I’d suggest trying to set your Garadget up on friend’s or neighbor’s WiFi just to establish if there’s any issue with the unit itself or it’s specific to the router. If you experience the same type of issue with the different router then we can try another unit.