Garaget won't connect to WiFi


#1

I am in the installation process of configuring the app to add my door. The Garaget has it’s dark blue flashing light and can be seen in the app as “PHOTON-XXX” (I’ve left out the special letters it generates). I click to connect to it, it finds my WPA2 WiFi network, but when I enter in my network password it waits for about a minute and then returns a big red exclamation mark with “error” below it and a “cancel” button. A coworker says he has seen this before with other devices and it could be a problem with the app’s inability to accept special characters like my password’s asterisk (*).

Also my unit during this process never flashes the laser to align the reflective pad, despite a few attempts between tries to hold down the “M” button for three to five seconds to reset the device.

I’m not sure if it is related, but at this stage in the setup I also have the two wire connection made to my garage door’s push button terminals.


#2

Garadget’s client software encrypts your password before sending it to the unit. It’s unlikely that the issue has to do with the asterisk.

What client software do you use to setup your unit (iOS/Android/Web)?
Does Garadget ever switch from fast blinking green (connecting to WiFi) to fast blinking cyan (connecting to server) then to slow pulsing cyan (connected to server)?


#3

I first tried the Android app and that is where I am getting this error. And no it stays flashing dark blue during the whole process.

I also have a Samsung SmartThings (gen 2) hub that I tried this on too. I published your device handler code and smartapp code, but I can’t get SmartThings to see my garaget, and then when I tried the smartapp it prompted for login to my account, but then returned an error “Error - bad state, unable to complete page configuration”

The web app let’s me login but quickly returns an error “No doors found”, obviously because my door sensor isn’t connected.


#4

There was a setup issue with the Android app reported by other users. While we’re figuring it out please try the web app using a different email address for registration.

BTW: If LED remained blinking dark blue then Garadget never received the login credentials for your WiFi network.


#5

Interesting, will try it out later when I am at home. The account I setup in the app returns the “No doors found” error, but then when I click to “add door” it returns an error “Organization not found for user”.

When I login with the new account I created and click to “add door” it gives more detail:

Power up your Garadget via microUSB connector on the back using included adapter or any other powered USB port
Make sure LED is blinking blue. If it isn’t, press and hold the ‘M’ button until it does.
Disconnect from your WiFi network and connect to the new WiFi hotspot created by Garadget. It will appear as Photon-XXXX on your network list.
Waiting for WiFi connection with Garadget

Will try later today and update my status. Thanks.


#6

Yes, it sounds like the symptoms described in another post. Yesterday I submitted the question to Particle Board as it is likely to do with their Android Device Setup Library.

The Android app developer and I will get our heads together to hopefully find some work around soon and publish the update.


#7

Im having a connection issue also. Im using the web setup. Device takes a few minutes to show up under my wifi. When i select the device Photonxxxx it wont connect. I have tried it a dozen times. Any thoughts?


#8

Tried using my iPad mini. The Mini doesn’t even pick it up. Tried it from a foot away. Tried it from further away, closer. Will not connect


#9

If your device is unable to connect to PHOTON-XXXX, I’d suggest making sure you’re keep it about a foot away from Garadget during the setup. Also worth trying with different device just to see if the result is the same.


#10

I reset the device (held button for 10 seconds) and was able to connect to it. Was able to set up both devices but only one shows up on web UI.


#11

@Iflyrcaz,

Try powering down and powering up Garadget again. Also logging out and logging back in. It may take some of this traditional technology voodoo for Particle network to report the device to the client software.


#12

I was finally able to connect to WiFi after many unsuccessful attempts at using the Android app by using the Web app. So my advice would be to do ALL of your startup configuration from creating your account to setting up your Garadget from the web app on either a your smart phone, tablet, laptop, or other device that can switch between wireless networks. After configured in the web app you can then try and connect with the Android or Apple IOS app.

I did have to create another login using a different email address than I had created in the Android app, not ideal but what do you do?. You will need to login to the site and create a new account. I had created previously an account from the Android app, but that account wouldn’t allow me to see or configure my Garadget from the web app.

Once you have created your account in the web app you should see your available Garadget appear as “PHOTON-XXXX” while still in the web app. You should be able to select it and provide it your WiFi network SSID and password. At that point it will drop off your list. You will need to change your device’s WiFi to connect to a new SSID being broadcast as “PHOTON-XXXX”, this being the device you just added connection to your WiFi. Your Garadget should likely have changed from blinking dark blue to pulsing a light blue while flashing it’s laser at your garage door. All still while in the web app you will then need to switch your device’s WiFi back to your home’s WiFi. It took several minutes for my Garadget at this point to show up in the web app or the Android app which time I used to align the garage door reflector pad and verify my push button wires were firmly plugged in. But at this point I am able to log into the Garadget Android app with the new account I had created and see and function my garage door. So again, my advice is to use the web app from start to finish on creating your account and configuring, and then once complete you should be fine to switch over to the Android or IOS app.

After using the Garadget it functions well in the Android app, but from my limited testing before having to leave for work it didn’t quickly register that a physical garage door button press had opened the door. But when I pressed in the app to open the door it updated in the app and became in sync with the actual state of the door. Functioning the door again in the app closed the door correctly, so maybe there is some time delay on updating the status of the door in the app (I only waited less than a minute). Aside from that I have yet to have the SmartThings plugin (device handler and smart app) connect to or function the device. I only get a “Error - bad state. Unable to complete page configuration.” error after entering my account email and password. I’m sure these issues will be worked out over time, and I’m pretty excited for this device.


#13

Nick, thanks for the detailed write up.
@fuzzyligic, any ideas about SmartThings plugin issue?


#14

No problem, I thought I would do a brief write up and save a few others from the stresses of trying to setup in the Android or IOS app. After another test from work I had my wife at home open the garage with the push button and I was able to see it open in real time in the app! So the issue of not seeing the state of the door seems to have been resolved.

Still any update on SmartThings integration would be much appreciated.


#15

I’ve got the SmartThings app running now! I just needed to follow the instruction and enable the oAuth setting from the SmartThings IDE site for this SmartApp. Thanks. The only thing not working at all for me is the Android app which just returns a generic “Unfortunately, Garadget has stopped” shortly after opening, but before loading my door. At this point I intend to use Garadget mainly through SmartThings so not having the Android app working isn’t a big concern at this time. I’ll be more than willing to try out updated versions or workarounds if needed, but my Garadget is as functional right now as I had intended it to be. Thanks for your support.


#16

@ndude07, glad to hear about your SmartThings integration success.
Re. Android app: try clearing app’s data/cache in system’s Application Manager.


#17

yes @ndude07 thanks for the update, sorry i wasn’t around earlier to answer this as i have been working away on business


#18

I had tried clearing the cache before I wrote that I was having issues with the Android app. Now with the latest version of the application that published this weekend the app seems to be running just fine. Despite clearing the app’s cache and force stopping it I was getting this error:

Parse error
nme=
OK

If I clicked OK the application loads and works, but incorrectly lists my garage as “Warehouse”. The application still functioned my garage, but had the wrong name. In my account I had my garage labeled as “Garage”, which is how it displayed in the web app. When I went to settings it had a different name “Home” that when I changed updated on the web app and now the Android app loads without error.


#19

@ndude07, Thanks for your report. I’ll look some more into default naming situation.
Sounds like your account is all set and running. Please share the installation pics if not too much trouble.


#20

4 posts were split to a new topic: Installation with Chamberlain LiftMaster Professional