IFTTT and Alexa not working anymore


#1

They were working fine up until about two weeks ago. I’ve changed nothing that I am aware of. I’ve deleted and recreated the applets. Installed and reinstalled the skill. Still… no joy.

Any ideas/suggestions where to go from here?


#2

Can you still log out and login into your account using the mobile and web apps?


#3

Yup. No problems there.


#4

What happens when you try to authorize the account with IFTTT or Alexa?


#5

It appears I’m authorized OK. Here’s a screenshot of the log:


#6

I’ve just recreated them and the applet “checks”. Still no action opening or closing. I noticed that the URL states https://api.particle.io**/v1/**devices/XXXXXXXXXXXXXXXXXXXXX Perhaps an earlier version?


#7

This doesn’t look like it’s coming from Garadget’s Alexa skill.
If you prefer to use maker webhook service, you can try testing the requests separately using one of many online web requests builders. Most likely the authorization token got expired.


#8

So, how do I renew the authorization token?


#9

This post describes your setup including the way to get the current authorization token. Please let me know if updating it doesn’t solve the issue.


#10

BINGO! The token had expired. I replaced it with the current one and we have lift-off! Many thanks, Denis.:slight_smile:


#11

Glad to hear that we got it sorted out.
Any reason for not using off-the-shelve Alexa skill?


#12

Well, they both seemed to fizzle at the same time. So, I just started with the IFTTT thing first.


#13

I have never managed to get the of-the-shelf skill to work. Whatever I say, in my New Zealand accent, the alexa says “sorry garageio is not installed”. I have tried “Garage-get” “Garage-It” “Garage-T” and lots of other variations. I have no idea how you Americans pronounce ‘garadget’ and I have given up trying. Come up with a name we can figure out how t pronounce.


#14

I use the IFTT skill and that works every time, just a pain to have to say “trigger open garage door”


#15

For the stock skill, try pronouncing with the “D” in it: garaDget [geredʐɛt]


#16

So “gara” “D” “get” should work?


#17

Yes, it works pretty reliably for me.


#18

Expiring tokens are annoying. Is this something we always have to remind ourselves to reset every 90 days or is there a more permanent fix to avoid expiring tokens?


#19

Garadget’s authentication was implemented to oAuth2 standard with the support support of refresh tokens - the mechanism intended for automatic token renewals.

I would expect more reports of this issue if everybody’s tokens were expiring on the regular basis. Please keep reporting and if this continues to be a problem, we’ll work on the solution.


#20

My tokens have been expiring every 90 days, but I just updated it without reporting it. I believe the next 90 days is up in August, I’ll let you know if it expires then.