New Android App

Tags: #<Tag:0x00007f2b7d4f92f0> #<Tag:0x00007f2b7d4f9228>

CURRENT STATUS
The new Android is now published in the Google Play Store.

Visit Play Store app listing
Signup for early access to future releases
APK Download for side loading

Screenshot:

What’s New:

  • Complete in-house redesign
  • New Gestures - additionally to tapping the door image, you can swipe it up to open, or swipe down to close
  • Tap the door in motion to stop it
  • Reporting for sensor health and ambient light in the garage
  • Deleting doors from account
  • Additional authentication mode for actions/edits only
  • Improved new device setup wizard
  • Added support for landscape orientation and larger screens

Posts below are in chronological order.
Please submit your feedback and requests for the new app in this thread.

I had lost my notifications for about a week or two ago. Nothing worked to get them back.
I uninstalled the old app and downloaded the new app. About 15 minutes later Everything
was loaded and working. I have my little friend back.
Thanks Denis
Tom j.

1 Like

Thank you for your early feedback.
The app is now submitted to Google Play’s beta testing channel and should be available without the need for sideloading after their review which normally takes few days.

I also stopped receiving notifications a couple of weeks ago and have now deleted the old app & installed the new apk. I now receive notifications but when I open the app, I see my doors for 1 second then get an off line warning. This happens when I’m on both home Wi-Fi and data. Probably something my end but thought I’d ask for help :grin::grin:

Paul,
Thanks for the info. I’ll need to add more info to the technical details section.
Does the message go away if you click refresh button in the header?

Thanks for your reply Denis - when I refresh, I see my two doors for a split second (like in the image in your first post) then I’m back to ‘Network Error.’ I hope this helps. If it helps further, when I click on ‘Service Status’ and move to a Particle page, everything is Operational?

Keep up the good work mate…amazing!

Paul

I haven’t tested departure alerts yet. But all the other alerts are working great. Great work on the app!

1 Like

I just installed the beta and I’m running into the same issue as BigPaul. Samsung Galaxy S10+

I tried a few things before uninstalling it. I cleared cache and data. I rebooted my phone. I checked permissions. The only listed permission was ‘location’ and it was denied, so I allowed it. I discovered that I could get into door settings if I repeatedly mashed refresh and quickly hit the settings icon. So there’s definitely no network error… the app just thinks there is.

Thanks for the bug report. This is super helpful. I’ll publish a new build and let you know when it’s ready to try.

No problem. I also signed up for beta testing on the garadget app in the android app store.

1 Like

The app is now available for beta testing from Google App Store without the need for side loading.

The APK link in the original post is also updated to a new build. The new build (beta 2) has error reporting for failed updates. This should shed some light on the network error issue reported above.

the new beta never showed up for me in the app store (it says i’m a beta tester). however, i downloaded the apk and the new version doesn’t have the network error. will test more later. i’m hoping that push notifications will start working for me again, i haven’t seen any in a few months.

I’d been having the notification issues so I decided to try the new app as well. I’ve with to the page and “pre registered” but I do not have an option to install. Is there something else I need to do?

Please try this link to signup as a tester via Google Play Store:

https://play.google.com/apps/testing/com.garadget.android

Using the new beta app, I tried to use the new feature of stopping the door while it’s in motion, and as a result the whole door went into a “stopped” state and I was unable to control it using the app anymore. It would try and open (already opened) and then close the door but it would just revert to the stopped state and the door was stuck open. I was only able to fix it by closing it using the web interface.

I wasn’t able to reproduce this issue with the test devices, but I’ll keep trying.
In my case the stopped door would open if tapped again or open/close if swiped up/down.
Can you try again and confirm that neither tapping nor swiped worked for you?

So, I was able to reproduce the same problem. I swiped up to open, and then tapped to stop the door during opening. Tapping again did nothing, another tap reopened the door. Tapping again to close the door wouldn’t work, and would just stay in the stopped state no matter how many times i tapped to open/close. However, sliding down to close the door was able to take it from a stopped state to being able to close.

Stopping the door during operation seems to be a hit and miss for me.

Hope that makes sense

Yes, when you tap a stopped door, the app doesn’t know if you want it to close from there or to open.
The implemented behavior opens the stopped door on tap.

The tap might not register if you slightly move your finger on the screen while tapping. I’ll see if this is a frequent occurrence and figure out some solution. Swiping is a recommended way to control the door with the new app.

So far, I’m not experiencing anymore issues with the latest beta app. Push notifications are now working for me again as well. Thanks!

1 Like