Unable to re-setup device


#1

Hello, I am trying to re-setup my device which was already configured. I tried “R”, the holding “M” for 3 seconds and 10 sec, but have been unsuccessful to re-add my door. The latest issue is, when trying to connect to the wifi network photon, I get an error saying unable to connect to network. I understand there is the usb setup route but I would prefer not to go that route if I don’t have to. Please help.

I am unable to get my device id as its not connected to my device.

RD


#2

Ron,
To get the device ID, please put your Garadget into listening mode, connect to the PHOTON-XXXX network and request following URL:

http://192.168.0.1/device-id

If you are at the most recent firmware (v1.20) then you can re-setup the WiFi connection using Garadget’s embedded web interface. For that again connect to the PHOTON-XXXX network and request following URL:

http://192.168.0.1/

If you are experiencing connectivity issues while setting up the device, please make sure it’s not mounted on the opener at that time. You can take it down by temporarily removing M4 screw holding main enclosure to the mount.

Please let me know if you need further assistance with this issue.


No Doors Found while light is Cyan
#3

Hi All,

I too am having the same issue as OP, was working fine for quite some time until 10 days ago.
I have tried the same steps as OP to no avail and also connecting to photon network and requesting web interface also with no luck. It’s currently sitting inside near the router.

Any other ideas


#4

Pierre,
You can try to re-flash the device with new firmware using the USB connection.
The process is somewhat techy so if you don’t want to deal with it, you can send your Garadget in for the warranty service.


#5

Thanks, for the reply. I have managed toy push it along a little further.

I tried pinging the device whilst attempting to connect it to the web interface, this got me into the web interface.

For some reason my WIFI password was wrong, so i changed it and saved settings, which took a couple of attempts to save.
I now have the laser activated, cyan flashing led with occasional red flash.

App still says it’s offline

What would you suggest from here?, Still the Re-flash? or is there something easier…


#6

Thanks for the update. From the symptoms it sounds like the encryption key may need to be refreshed.
The process is still a bit tech’y. Please take a look and if this isn’t something you want to deal with then we’ll handle this issue under warranty.


#7

Ok, with your help i’m getting so close. I had a look at the process and gave it a shot.
Without going to far off topic for this thread I am getting stuck on the last command

particle keys send [device id] photon.pub.pem

It returns Error sending public key to server: Permission Denied

I am making the assumption all commands are whilst in DFU mode, I used my Dev id in the brackets.

I am hesitant to send back yet as living in Australia would be a 4 week + turnaround.

Any tips?


#8

Congrats on great process with the solution. Yes, the permission message can be fixed:

If you have Particle CLI installed then temporarily remove the device from your account by running:

particle device remove [device id]

then after fixing the keys, you can add it back with:

particle device add [device id]

If you don’t have CLI or don’t want to deal with it, please PM me the device ID.


#9

Great news Dennis…It’s breathing cyan and back online.:grinning:

Thanks for your help, Instructions were well written.

Just for others you will need to reboot after fixing keys from the process mentioned above before adding the device.


#10

I am getting multiple light blue with occasional red laser. did the reflashing but getting error on last command. Looks like the particle command is adding a .pub into the file name???

PS C:\Users\Lee\AppData\Local\particle\bin> particle keys send 2a005200XXXXX53530333533 photon.pub.pem
Couldn’t find photon.pub.pub.pem
I replaced the middle 5 numbers with X’s just in case that number needs to stay private but when i enter the command there are no X’s

Unable to see the device in the app at any time. Also cannot see it in the web interface and the site just loops around infinitely asking me to create a new account.

Any help would be appreciated


#11

Sounds like you are pretty close. Does the file exist in the directory?
photon.pub.pub.pem ? maybe it’s called photon.pub.pem instead?


#12

There is a file called photon.pem
Tried executing: particle keys send 2a005200175XXXXX30333533 photon.pub.pem
and: particle keys send 2a0052001751XXXXX0333533 photon.pem
and: particle keys send 2a005200175XXXXX30333533 photon…pem
I either get this result: Couldn’t find photon.pub.pub.pem
or: ENOENT: no such file or directory, unlink ‘C:\Users\Lee\AppData\Local\Temp\118107-9800-j68t5q.pub.pem’


#13

I think i forgot to mention a change I made to the 5 steps in this thread
When I run the command: Particle Keys New Photon
I get this result: PS C:\Users\Lee\AppData\Local\particle\bin> particle keys new photon
Error creating keys: Command failed: C:\Windows\system32\cmd.exe /s /c “openssl genrsa -out photon.pem 1024”
‘openssl’ is not recognized as an internal or external command, operable program or batch file.

So I guessed that i should create a shortcut to openssl.exe in my working directory and run this command instead of Particle keys New photon: C:\OpenSSL-Win32\bin\openssl genrsa -out C:\Users\Lee\AppData\Local\particle\bin\photon.pem 1024

And that does create a file called photon.der in my working directory, but now I am thinking that there are more steps in the Particle Keys New Photon that are not getting completed. What are all the commands that occur in the Particle keys new photon command? or is my adaptation acceptable?


#14

If you get “‘openssl’ is not recognized” error then you need to call that with the absolute path or add the directory containing that program to the path environment variable on your system.

You can find more information about resetting the encryption key at in the Particle Community Board.


#15

I did that as described in the same post. Please read the entire reply to see if i called it with the corre t path or if there are other commands. Its frustrating trying to fix this and not return it to amazon when you dont read the reply that took me several hours to figure it out.


#16

Lee,
Here is how the process looks when I do it. Please check your steps and compare results. Let me know at what step your results are different and I’ll try to help.

  1. Downloaded cloud_public.der. Now folder contains cloud_public.der
  2. command:

dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

folder contains: cloud_public.der

  1. command:

particle keys server cloud_public.der

folder contains new file: cloud_public-padded.der

  1. command:

particle keys new photon

folder contains new files: photon.pem, photon.pub.pem, photon.der

  1. command:

particle keys load photon.der

folder contains new files: backup_rsa_photon.der, backup_rsa_photon.pub.pem

  1. command:

particle keys send XXXXXXXXXXXXXXXXXXXXXXXX photon.pub.pem

no new files


split this topic #17

20 posts were split to a new topic: Encryption Key Fix