SmartThings App

Thanks to the open nature of Garadget and enthusiastic support from the developer community, now your Garadget can be used with SmartThings home automation system.

1 Like

So welcome guys and gals, as the author of the SmartThings Integration, if you have any issues with the install or comments when you come to use, please post them here or in the release thread.

The Integration has been submitted to Smartthings to become an officially supported device which will simplify the install process, however in all likelyhood this will not be in place before Garadget starts shipping.


Someone needs to take me by the hand and lead me like a small child thru the process…

When creating a new SmartApp on the SmartThings website, in addition to Namespace (which I assume is fuzzysb/SmartThings/blob/master/DeviceTypes/fuzzysb/Garadget/Garaget.groovy) …what else do I do ?

Is there an app to download ?

Sorry and thanks in advance !

Hi, I was able to add the Garadget device to my ST Hub using your code. I have an automation routine set up to open the device when someone arrives but the automation routine does not work. I can manually trigger the device to open or close but cannot get an automation to work. Any suggestions would be welcome. Thank you. Andy

@andyainsc you’ve not given me a lot to go off. my device works against both the Switch and Garage Door Control capability.

I take it that when you said you used an automation routine you meant that you have used ST routines? in which case then it can only be using the switch capability as they do not support the garage door capability. but when you click open/close directly in the device handler, this also uses the same function. and as that works its not an issue with my code. it is an issue most likely with your routine.

the only thing you can do to troubleshoot is to look at the live logging when it is triggered and see if the device handler is actually being triggered. could i also suggest you look at using CoRE and create a rule that fires when a routing is triggered, it makes it easier to test and maintain

Hey there. Why is the report or notification lagging. So when the garage is open then certain lights switch on to warn me incase i forget.
Love the intergration but the lag makes routines a buzz kill.
Would love to donate by the way

@fuzzyligic First off, thanks for this code and integration. I have done everything and can find Garadget (Connect) under Marketplace/My Apps but the credentials does not work - it does not let me connect my Garadget account to SmartThings. The login step asks me to check my Garadget login and password. I have verified multiple times on the Garadget app that the username (my email) and password is the same as I am entering in Garadget (Connect). any idea why this is happening?

@abhi.ko sorry its taken me so long to get back to you.

yes its a strange issue for sure. could you please PM me the logs from the Garadget (Connect) section of the live logging window when you are attempting to put in your username and password.

failing that if you would like me to correctly troubleshoot. if could set a temporary password on your account and provide me with the details. if you are worried about security you can disconnect your garadget from the opener and i can troubleshoot directly and hopefully replicate the issue to come up with a fix.just PM me either the log or your details.

SmartThings does not see my Garadget unit, during the last phase of linking the Garadget app with the SmarThings smartApp.
Instead it only sees my other three Photons devices I have in my house(that control LED lights)

Please advise.

What is the best way to ask questions with respect to troubleshooting?

Thank you very much for putting the tutorial together in GitHub!

Ask away.

What is the issue you are having?

If it’s an issue once the device handler is installed. You can grab the log from smartthings logging and DM me it.

Can I hire someone to install the app in ST? Who wants to make some money?

First of all, thanks fuzzyligic for your job. I have a problem. I connect ST to Garadget with my credentials. The reply is: Credential Accepted! Garadget is now connected to SmartThings! Then I press the NEXT button, but in the “Choose devices” windows i have: “Select Device(s) You can’t currently add this”.
Can anyone help me.

Hi everyone I did all the steps to add this in Smart things via the instructions, but when I go into the smart things app on the phone and enter my correct UN and PW it will not let me login
Is there a FIX or another way you all can share to get Garadget on my smart things
Thanks all

@garadget @fuzzyligic Hi Denis & Stuart, currently I’m using IFTTT to trigger my smart lights when the garage open/close. Is it possible to do that with this integration?

Thank you very much and thank you Stuart for writing all this code for everyone!

1 Like

I am having a similar issue. I have followed the instructions and when I attempt to add the Garadget SmartApp In ST I get a page with the message “please check your username and password”.

I can access the Garadget account with their iOS app on my iPhone, iPad, and through web access. I have even changed my password. After the change it still does not work with the ST Garadget Smart App but does work from all other interfaces.


I’m tagging in here also but this is now broken on Hubitat also. Can not log in via app even with correct credentials and OAuth being turned on.

@garadget @fuzzyligic any chance this app will get updated in the future at some point to support the new Auth method?

@ecastete Same thing happened to me. I followed the integration instructions to the teeth. Just like yours, ST kept giving me same message “please check your username and password”. I tried changing Garadget password. Still no luck.

If anyone else ran into this problem and found an answer please let us know. Thank you very much.

Hi Garadget community, i got this product recently and installed it today. Installation went fine but integration into SmartThings isn’t yet working for me. A lot of other people are having the same issue, which is that the SmartApp can’t create an authentication token with, response is that credentials are invalid.

I suspected it could be special characters (although I see it’s url encoding them) so I changed my password to something simple, and I can see I’m typing it correctly via what’s in the logs, but it continues to say invalid credentials.

It looks to be a problem at and not with you guys, but is there someone who can help me to resolve it?